Snapshot download failed

Hi,

I have created a snapshot and when I try to download it states Failed - Network error

  • Dimitris
    • Support Star

    Hey there Laurence,

    I really hope that you're having a beautiful day and thanks for reaching us! :slight_smile:

    I have created a snapshot and when I try to download it states Failed - Network error

    As this seems a pretty general error message I'd like you to grant us with support access to the site confronting this issue in order to have a better look and to try re-produce it in our test installations. You can find detailed information about it in https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Warm regards,
    Dimitris :slight_smile:

  • Adam Czajczyk
    • Support Gorilla

    Hello Laurence!

    Thanks for granting access. I visited the site and I tested two snapshots from the list (those on top of the list) and I'm getting the same error.

    The Snapshot log file doesn't indicate any errors related to archive creation though. Could you please login to your server (WordPress install) using FTP client (e.g. File Zilla or similar) and then check whether snapshot .zip archives are present inside

    /wp-content/uploads/snapshots/

    folder?

    If they are there:

    - try do download them via FTP and then extract (unzip) on your local drive just to test if this works
    - check permissions for these files
    - check permissions for "/wp-content/uploads/snapshots" folder

    Let me know please about results.

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Laurence!

    What should the permissions be?

    Generally the file should be "readable/downloadable" but may work slightly differently on different servers. For example: 0400 permission may not give a right do download if an owner of a file is different than the owner of webserver process running and/or FTP user. However 0644 or 0655 or 0755 should work.

    That said, let me know please what did you find so I knew where to head on from there with further investigation (if necessary) :slight_smile:

    Best regards,
    Adam

  • Laurence
    • Flash Drive

    It was on the server and I was able to download via FTP. I uploaded to the new site but it did not work fully. It said that there was a url mismatch and when I restored the snapshot on the new site it restored the themes and plugins but the new site was just the vanilla wordpress and the subdomains were not restored.

  • Adam Czajczyk
    • Support Gorilla

    Hello Laurence!

    It was on the server and I was able to download via FTP.

    Thanks for letting me know about it. That means that at least the snapshot archive was created properly so now we need to find out what's causing download errors. Have you also checked file/folder permissions?

    t said that there was a url mismatch

    That's perfectly fine if you're restoring from either a single install to a multisite or from one domain to other domain (regardless whether it's a multi or a single site). On Multisite Snapshot should be then asking you to select to which of existing (sub)sites you wish to restore it.

    it restored the themes and plugins but the new site was just the vanilla wordpress and the subdomains were not restored.

    Snapshot doesn't restore Multisite that way. In order to restore multisite site you'd first need to create separate snapshots of each sub-site of a "source" site and then:

    - create regular sub-site on a "target" site manually
    - restore selected snapshot to it

    Our developers are working on a "full multisite backup" feature but I'm not able to predict when it will be added to the plugin. We may expect this in future but I can't give any ETA for it.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.