Snapshot end in 404 NGNIX

Snapshots are not working properly (not managed backups). They end in a 404 NGNIX.

  • Adam Czajczyk

    Hello Thiago,

    I hope you're well today and thank you for your question!

    I have checked the site and I think there are to important issues there to start with.

    1. Your site appears to be infected. The Defender plugin (See "Defender -> File Scanning") finds at least two files that appear to be maliciuos:

    /home2/clubeter/public_html/wp-admin/css/colors/ectoplasm/klqyoxcv.php
    /home2/clubeter/public_html/wp-includes/Requests/Exception/Transport/qbnkzqwp.php

    I checked these files and they definitely should not be there. However, even though I removed them, I cannot be sure if there's no more malicious code anywhere (while Defender detects most of it, there's always a chance that something is e.g. "sitting in the db" waiting for some "trigger" to be added) and the fact that these files even got there, means that there's some security loophole. I would strongly recommend cleaning up the site then.

    In case you needed somebody to do it for you, please consider hiring a pro who could do such clean up for you.

    For posting requests for such sort of jobs, you might want to consider Codeable.io where you could even get a nice discount for a first job, see here:

    https://premium.wpmudev.org/partners/

    2. NGINX Time-out

    It seems that the setup of a server is that there is an Apache web-server that's directly handling your website and there's nginx "in front" of it, which means that all the requests first go through nginx and then are directed (if necessary) to Apache.

    That, in fact, is a very robust configuration but has its downsides. One of them is that, unfortunately, the fact that regardless of max_execution_time setting in Apache and other "time out" settings of it, nginx will terminate requests that take too long anyway - by its own rules.

    It seems in this case like it is terminating after around 20 seconds. Recommended timeout for Snapshot is 160 seconds or more as some requests might take quite long, especially if there are bigger files or there's more files to be processed. Now, with such server config Apache would be able to handle such longer requests (and Snapshot detects that Apache meets requrements) but the nginx server in front of it - through which requests goes too - is terminating it long before Apache would do.

    The question is, though, whether it's possible to change NGINX settings to allow longer timeout. If not 160 or more seconds, then at least rise it as much as allowed. That said, would you please check your hosing control panel to see if you got any option to change that?

    If not, please get in touch with your host and ask them if they could increase that for you.

    Let me know about results and we'll see then what to do next, if necessary.

    Kind regards,
    Adam

  • Predrag Dubajic

    Hi Thiago,

    Since Snapshots use PHP for the backup process it sometimes need bit more resources to finish everything properly.
    So if there are a lot of plugin files and media files sometimes the server is unable to handle number of requests needed to back up all those files and excluding some plugins does the trick like in your case.

    You can also try creating separate Snapshot only for plugins and keep them backed up that way.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.