Snapshot ERROR: PclZIP - I can?t make backup

ERROR: PclZip table: Array: add failed: -10: Unable to find End of Central Dir Record signature [code -10]]

without data base:

ERROR: PcLZIP file:media/2014/07 add failed -10: Unable to find End of Central Dir Record signature [code -10]

The plugin does this error in any situation: only database; only files, all tables, add tables ...

What should I do to fix this?

Thanks

Paulo

  • Tyler Postle

    Hey Paulo,

    Hope you're doing well today! Thanks for your question.

    This could be a memory issue. Can you try adding this to your wp-config.php

    define('WP_MEMORY_LIMIT', '256M');

    add that anywhere above the /* That's it, happy blogging */ text.

    Can you also take a look in your wp-content/uploads/snapshots/_logs folder and find the log of a recent snapshot. If you can copy and paste the contents here that would be awesome :slight_smile:

    That could give us more info into what is causing the issue.

    Look forward to your reply!

    Cheers,
    Tyler

  • Paulo

    I found the logs. Each file have 2.4 MB. I´m paste the 10 first line and 10 last line.

    first line: 2014-08-03 13:05:37: Backup: init
    2014-08-03 13:05:37: updating snapshot: 1407019471
    2014-08-03 13:05:39: file: section: media
    2014-08-03 13:05:39: Warning: errno:2 set_time_limit() has been disabled for security reasons /home/euna/public_html/wp-content/plugins/snapshot/snapshot.php on line 3330
    2014-08-03 13:05:39: Warning: errno:2 php_uname() has been disabled for security reasons /home/euna/public_html/wp-admin/includes/class-pclzip.php on line 5672
    2014-08-03 13:05:39: Warning: errno:2 php_uname() has been disabled for security reasons /home/euna/public_html/wp-admin/includes/class-pclzip.php on line 5672
    2014-08-03 13:05:39: Warning: errno:2 php_uname() has been disabled for security reasons /home/euna/public_html/wp-admin/includes/class-pclzip.php on line 5672
    2014-08-03 13:05:39: Warning: errno:2 php_uname() has been disabled for security reasons /home/euna/public_html/wp-admin/includes/class-pclzip.php on line 5672
    2014-08-03 13:05:39: Warning: errno:2 php_uname() has been disabled for security reasons

    Last lines:

    content/themes/twentyfourteen/js/html5.js
    [518] => /home/euna/public_html/wp-content/themes/twentyfourteen/js/keyboard-image-navigation.js
    [519] => /home/euna/public_html/wp-content/themes/twentyfourteen/js/slider.js
    [520] => /home/euna/public_html/wp-content/themes/twentyfourteen/languages/twentyfourteen.pot
    [521] => /home/euna/public_html/wp-content/themes/twentyfourteen/page-templates/contributors.php
    [522] => /home/euna/public_html/wp-content/themes/twentyfourteen/page-templates/full-width.php
    )

    )

    )

    [snapshot_time_start] => 1407071138
    )

    2014-08-03 13:05:44: file: output:
    2014-08-03 13:05:44: memory limit: 256M: memory usage current: 51.64M: memory usage peak: 57.41M

    If you need, I can send the file.

    Thanks,

    Paulo

  • Tyler Postle

    Hey Paulo,

    Thanks for your patience here and pasting that in :slight_smile:

    Is there any other warnings or anything that you can find in there? If you could attach the file that would be great.

    Warning: errno:2 set_time_limit() has been disabled for security reasons /home/euna/public_html/wp-content/plugins/snapshot/snapshot.php on line 3330

    This warning is often given because of restrictions from your host to stop your site from hogging all the memory and slowing down other sites.

    You might want to contact your host and make sure they aren't pretty any restrictions on their end that could be causing this. It will help narrow down the possibilities too :slight_smile:

    Look forward to your reply here Paulo!

    Cheers,
    Tyler

  • Tyler Postle

    Hey Paulo,

    Very sorry for not getting back to you earlier on this one :slight_frown:

    If you are interested, I do have another solution for you!

    I think this issue has to do with the writing permissions on your wp-content folder.

    You can resolve that by doing this:

    1. Locate the wp-config in the root of your WordPress directory.
    2.Take a copy of the wp-config.php file
    3.Create a TMP folder in the wp-content
    4.Open the wp-config.php file with a text editor
    5.Add the following code to the last line of the file and then save
    define ('WP_TEMP_DIR', ABSPATH . 'wp-content/tmp');

    I'll keep a close eye on this thread in-case you want to try this out and need further assistance at all. This error was a tricky one for me as I hadn't seen it before!

    Hope the rest of your week goes well Paulo.

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.