snapshot error when wpmdevu dashboard appears during restore

the snapshot is not restoring fully and missing out media. I tried to restore again, and it completes with a full media library but when i add images to the media library they do not show and i just get a box with a small black cross. i have tried several fresh installs and two different snapshots. Each time, the restore gets as far as restoring media, gets to 67% and then the wpmudev login box appears and that seems to be the end of the restore. can u help with this please.

  • Michael Bissett

    Hey @karen, hope you're doing well today! :slight_smile:

    Could you provide a screenshot of this login box that you're seeing here? Also, could you please send in the following, so that we can diagnose this further:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include a copy of the snapshot in question (you could store it on Dropbox, to make the sharing of it easier)
    - Include any relevant URLs for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks a bunch! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @karen, my apologies for the delay on this thread here!

    After testing things on a brand new subfolder WordPress install of mine, it seems like the snapshot you sent over isn't behaving as it ought to, I'm seeing these errors at the top of the page:

    Warning: fopen(/index.php) [function.fopen]: failed to open stream: Permission denied in .../dev7/wp/wp-content/plugins/snapshot/lib/snapshot_utilities.php on line 1019
    
    Warning: fopen(/.htaccess) [function.fopen]: failed to open stream: Permission denied in .../wp/wp-content/plugins/snapshot/lib/snapshot_utilities.php on line 1026
    
    Warning: fopen(/CACHEDIR.TAG) [function.fopen]: failed to open stream: Permission denied in .../dev7/wp/wp-content/plugins/snapshot/lib/snapshot_utilities.php on line 1034

    That, and some of the database entries don't seem to have been updated (one of them being the upload path, which makes me wonder about the media library issue on your site...).

    What's the site that you're using to create the snapshot? I'd like to have a closer look at it, could you please send in the WP Admin details & FTP details for that site via email?

    Also, could you send in the WordPress access details for that test site you mentioned, and check the FTP access details for it? (wasn't able to get in via FTP to check there)

    Thanks! :slight_smile:

    Kind Regards,
    Michael

  • Adam Czajczyk

    Hello Karen,

    I hope you're well today and I apologize for the delay.

    What you've described points me to thinking of php script execution time and/or memory limits. Backup creation is quite a resourceful process and as such it results for WordPress php scripts to require a bit more time to complete and more memory. That being said, first of all I'd try to increase both those values.

    To increase php execution time install this free plugin from WordPress repository: WP Maximum execution time exceeded. After that connect to your site via FTP and follow the steps below:

    1) download entire site (WP install) to your local drive or other backup location; this is just to be sure that the changes would be reversible in case something goes wrong
    2) open wp-config.php file in your favorite text editor (for Windows Notepad should do just fine)
    3) at the very beginning of the file, right after <?php tag (line below) add this line:

    define( 'WP_MEMORY_LIMIT', '64M' );

    If you're using W3 Total Cache or similar caching plugin it's possible that there'll be a line similar to "define('WP_CACHE', true);". In this case add aforementioned code below it.

    4) Save the file (and upload it to the server if you've edited it on your local machine).

    Now try to perform backup with Snapshot again. If it still stops at the same place please try to increase memory limit (see steps 1-4) subsequently to 96M, 128M and 256M. If it still doesn't help please note the time of failed backup operation. By time I mean how long did it last from the beginning until the fail. Also let me know of any other possible errors or odd behaviours.

    Hope that helps,
    Cheers,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.