Snapshot failed backup files

I have tested Snapshot on several sites, both Managed Backup and local failed when backing up files.

It's either "An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings.", "<empty response>" or it fails with a 404 page inside backup tab.

Tried increasing WordPress memory, PHP max_execution_time and using various Snapshot flags in wp-config.php but still failing at files backup.

  • Dimitris
    • Support Star

    Hello Chris

    I've tried to make a few more changes and create a Managed Backup, with no avail though. :slight_frown:

    I've already escalated this to our developers, for further investigation. Please keep in mind that their response times are larger than ours, thus your patience here is highly appreciated!
    Me or another colleague of mine will keep you posted here, as soon as possible.

    Thank you,
    Dimitris

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Hi Chris ,

    I've removed all custom defines and kept only logging enabled. You'll find 2 new backups, 1 local and 1 managed that went through fine.

    I didn't see any hiccups in the logs as well.

    Just for your information if you're on a shared host the server might be low on resources some times resulting in various I/O errors. There's nothing we could do about that on our end though.

    The only thing you could do that might help in that case is just choose different chunk sizes for files / database by :
    define( 'SNAPSHOT_FILESET_CHUNK_SIZE', 50 );
    define( 'SNAPSHOT_TABLESET_CHUNK_SIZE', 50 );

    Everything seems fine for the time being since both backups completed without errors.

    Regards,
    Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.