Snapshot failing to backup

Hello, I've installed Snapshot. It doesn't show it in the list of plugins!

It says: An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings.

It stops at Files: : plugins - 86% (12/14)

Please help me

Edit: I've deleted the plugin and tried re-installing it thrice. I also deleted any remains via ftp before installing the plugin again.

    Adam Czajczyk

    Hello islaxmi,

    I hope you're well today and thank you for your question!

    Would you mind granting me a support access to your site? I would like to take a closer look and check it myself so I could hopefully find out what is happening.

    In order to enable support access for me, please follow this guide and let me know here when you're ready with it:

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Best regards,
    Adam

    Adam Czajczyk

    Hello islaxmi!

    Thank you for granting access.

    I checked the site and I noticed that one of the ajax calls during the process times out, as a result returning "404 not found" response to the script. That's causing it to break. That happens during backup of one of the plugins and is most likely because one of the plugin's files is too big for your current setup to handle that way.

    Let's start with then with improving some setup aspects to make time out less likely. First step would be to increase WP memory limit which is currently 64M out of 128M assigned to PHP scripts. To raise it please add following line to the "wp-config.php" file of your site:

    define('WP_MEMORY_LIMIT', '128M');

    Make sure please that this line is located above the "/* That's all, stop editing... */" line in a file.

    The second step would be to increase maximum allowed script execution time for PHP. That's currently limited to 30 seconds while the default maximum for an Apache web server is 300 seconds. I don't know if your host puts any additional limit on that but we can safely assume that more than 30 seconds would be allowed on server so let's try to raise it to that value.

    There's more than one way to do this, so please try following options:

    1. Check your cPanel for PHP options/configuration; if there's such section available, look for

    max_execution_time

    option and set its value to 300.

    2. If that is not available in your host's cPanel, try adding following lines to the very beginning of your site's .htaccess file:

    <IfModule mod_php5.c>
    php_value max_execution_time 300
    </IfModule>

    Assuming that it didn't break the site, go to "WPMU DEV -> Support" page of your site's dashboard after it's added, click on "System info" button, switch to "PHP" tab and check the value of "max_execution_time". If it's 300 instead of 30, it means that this way worked.

    3. If way #2 didn't work, remove aforementioned code from ".htaccess" file and then

    - create an empty file named php.ini in a root folder of your domain/WP install
    - put this line inside

    max_execution_time = 300

    Again, check the value on "WPMU DEV -> Support -> System Info -> PHP" page.

    If any of these ways worked, clear your site's and browser cache and check if snapshot now completes.

    Let me know please about result.

    Best regards,
    Adam