Snapshot fails when reaching the /media/ folder

I’m trying to create a complete snapshot on my site, but it fails and it gives no error message.

I checked the log and the snapshot failed right after reaching the /media/ folder.

  • James Morris
    • WordPress Enthusiast

    Hello Dominique

    I hope you are well today.

    This issue has been flagged for our SLS Team (code experts) so that they can dig into this issue further for you. An update will be posted here as soon as more information is available. Thank you for your patience while we sort through this issue.

    Best regards,

    James Morris

  • Ari
    • Recruit

    Hey Dominique

    Hope you are fine today!

    I managed it to work!
    All I had to do is add the below code:
    if (!defined('SNAPSHOT_FORCE_ZIP_LIBRARY')) define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'ZipArchive');
    Instead of this code:
    if (!defined('SNAPSHOT_FORCE_ZIP_LIBRARY')) define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');

    What was the issue with pclzip?
    The issue is pclzip have a limitation of file size, file should be minimum of 18 bytes file size.

    When snapshot trying to backup media folder it finds a file which is below 18 bytes, which is in the snapshot folder. That's why it's throwing the error:

    But this is not happening in our test sites, I don't know how this file get generated, I have escalated this task to our plugin developers, they should have a review on it, please don't remove the site access and FTP access now.

    I could created two snapshots backups successfully:

    I will inform whenever I get something from our devs.

    Have a great day!
    Best Regards,
    Ari

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.