Snapshot file backup not working

I have two scheduled backups, one for the database and one for files. The one for the database is running fine and sending backups to Google Drive. The one for the files is doing nothing. It's a good size site. In fact, the wp-content directory, when zipped via the cPanel, is 1.78GB.

Are there limitations to the size of the backups?

  • Nazmul H. Rupok

    Hi there,

    I hope you are doing great today and thank you for contacting us. I am sorry that Snapshot Scheduled backups are not working well for you. 1.78GB should cause no issue but you need to make sure you have enough memory and execution time to execute such large backup.

    Please do the following for me which is a major step towards resolving the issue:

    1. Enable debug logging. You can do this by adding the following lines to your 'wp-config.php' file:

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    2. Increase WordPress memory limit:

    define( 'WP_MEMORY_LIMIT', '256M' );

    3. Add the following lines which are specific to Snapshot settings:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);

    4. Increase max execution time to 300 or more by trying the following methods.
    a. Create or edit php.ini in your website's root and add the following line:
    max_execution_time 300

    b. In .htaccess add the following line:
    php_value max_execution_time 300

    c. in cPanel you can go to "Software > MultiPHP INI Editor", choose your domain and PHP version and change the value for max_execution_time to 300 or more

    After that you can try Snapshot again, please try to set it to "Daily" so that we can have results soon for the Scheduled Backups, you can change later.

    Let me know how it goes.

    Best regards,
    Nazmul

  • Janna

    I updated Snapshot and can see the Max Execution time warning which states it's 120. I added the php variable using my cpanel which created a php.ini file at the root level with the below code:

    max_execution_time = 300
    zend_extension=/usr/local/php56/lib/php/extensions/ioncube.so
    zend_extension=/usr/local/php56/lib/php/extensions/ZendOptimizer.so

    When I then "re-check" the snapshot requirements, it still shows 120.

  • Predrag Dubajic

    Hi Janna,

    There's no real difference from setting up Snapshot on Single and Multisite installation so this is not the issue here.

    Would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Please respond in this thread once access is granted.

    Best regards,
    Predrag

  • Nastia

    Hello Janna

    Hope you are doing well!

    I am afraid the support access is not enabled from our end. Would you please send to us your credentials?

    You can send credentials by using our secure contact form
    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: “Attn: Nastia”
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant URLs

    Looking forward to your email!

    Cheers,
    Nastia

  • Nastia

    Hello Janna

    Hope you are doing well!

    During the file backup, the 504 Gateway Timeout error showed up in the developer's console.

    The gateway did not receive a timely response from the upstream server or application.

    I've added the following line to make the backup file chunks smaller, but unfortunately, it didn't solve the issue:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_IGNORE_SYMLINKS',true);

    504 is a server error, so the server resources might be limited to complete a backup this large. Usually increasing max execution time solves this. The current value is already set at 1000 sec

    I've also increased the max memory limit to 1024. The line that defines memory was added in the incorrect place in the wp-config.php file, though unfortunately, this didn't solve the issue.

    I've flagged here second level developers so they could have a closer look at your site and provide some feedback.

    Have a nice day and take care!

    Cheers,
    Nastia

  • Lindeni Mahlalela

    Hello Janna,

    I hope you are doing great today. Thank you so much for reporting the issue to us and thank you for your patience so far.

    I was able to have a look at your site and made some changes in your wp-config.php file located in your document root. I have added the following lines of code:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600); //~100MB
    if (!defined('SNAPSHOT_FORCE_ZIP_LIBRARY')) define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');
    if (!defined('SNAPSHOT_IGNORE_SYMLINKS')) define('SNAPSHOT_IGNORE_SYMLINKS', true);

    These are Snaphot specific configuration parameters.

    I have also re-arranged the code in your wp-config.php file as I noticed that some of it was repetitions and that it is recommended that all custom code to this file be added above the line:

    /* That's all, stop editing! Happy blogging. */

    So I moved all custom entries above this line and grouped related entries to make it easier to read and follow. (I hope the rearrangement does not get me into trouble)

    After doing this, I was able to create a backup of your media using Snapshot but only selecting the uploads folder for backup. I then attempted a full backup, I created and named it "Full Snapshot", it failed when backing up the folder: ''/wp-content/uploads/wpallimport/logs", then I went to "Snapshot > Settings" and in the "Global File Exclusions" section I added the folder path:

    wp-content/uploads/wpallimport

    To exclude the wpallimport folder which seems like duplicate import and the logs file is huge. According to my opinion the logs are not necessary to be included in a backup so we can just exclude the logs folder in there. Once I have done that, I was able to run the Snapshot 'Uploads Directory" successfully.

    If you like, to make the backup lighter then you should consider excluding more folders or specific files by adding them in the exclusions list, this will make the backup quicker and only backup the necessary files that are required by your website.

    I hope this helps. Please let us know if you have any further questions.

    Have a nice day.
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.