Snapshot has stopped working.

Hi There,

I'm struggling to get snapshot to work. It was working previously, but has now stopped and is giving a <empty response> error. Please see attached.

Thanks again

Dan

  • Dimitris

    Hey there JazzyDan,

    I trust you're doing good today! :slight_smile:

    Could you please access your server via FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Ref: https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    After doing so, go to Snapshot -> Managed Backups -> Settings [box] and activate the "info" debug level for all instances.

    Then go ahead and try to replicate the error, either hit the "Backup Now" button or set a daily schedule. If you choose the manual backup, please don't close the browser window until the procedure is over.

    When this is finished, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. If size of text file exceeds the 5MB limit of our blog, please use a service like Dropbox and post the shareable link instead.

    Finally, grant us with temporary support access to the website in question via WPMUDEV Dashboard plugin as described in next link (no need to share any credentials):
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Looking forward for your results!
    Warm regards,
    Dimitris

  • Adam Czajczyk

    Hello Dan!

    Thank you for granting support access.

    I checked the site and run Managed Backup manually and it completed fine, with no errors. It wasn't sent to the cloud because I got logged out (WPMU DEV support access tool logs us out from time to time for security reasons) but it got saved locally.

    I suppose what happened might have been related to some temporary spike in site usage (meaning site being close to hit server resource limits). I think it would be good now to make Snapshot process data in smaller chunks - as it should lower its resource needs a bit - and then give it another go to see what happens.

    That said, please add following lines to the "wp-config.php" file right above "/* That's all, stop editing */" line:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);

    Do it please while scheduled backups are still disabled, then enable them back and let them run to see if they work again. Do not remove please debugging lines suggested by Dimitris as if anything goes wrong again it might create debug.log this time and give us some additional info.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Dan!

    Thank you for your replay.

    I accessed the site again and this time made sure that I don't get logged out. You can see on the list that entire backup has been created and uploaded to our cloud. It took several hours but it worked. I'm wondering whether this is somehow related to the browser and/or internet connection. That seems highly unlikely but it's worth checking.

    For now, could you please enable scheduled backups back? If I remember correctly they were set to weekly so you might want to set them to e.g. daily so we wouldn't need to wait entire week for next run. Let's see if that automated backup will complete for you please.

    Kind regards,
    Adam

  • JazzyDan

    TBH I think the problem is more related to bad hosting provided by Heart Internet. I plan to move this to my other hosting soon. My internet connection this end is fantastic a constant 200mb up and 200mb down so unlikely to be an issue, I also get the same issue in both Safari and Chrome, so unlikely to be the browser.

    I will set up the scheduled back-ups and keep an eye on it.

    Thanks again

    Dan

  • Adam Czajczyk

    Hello Dan!

    I too think that browser doesn't have anything to do with this but just wanted to make sure since I was able to run these backups while you couldn't. That might however be kind of "combined" issue of a location of "user, WPMU DEV servers and your server" or indeed the host is not quite able to handle it.

    Let's see how scheduled backups will work now and if switching provider will help. Feel free to post here anytime and we will "jump back in" :slight_smile:

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.