Snapshot import not working from Multisite Subsite to Single Installation

I am separating a single site from a Multisite install as a test of the tools.
I have been following this tutorial, which was given to me by support here a few days ago,
https://premium.wpmudev.org/blog/easy-migration-snapshot/

I have tried to save the backup both in local server and also to Dropbox but can not import it in the new single installaton.

I am getting this error message: Error: Manifest data not found in archive.
Oh no! One or more of your Snapshot archives was not imported successfully. Please check your Snapshot logs for more details, or try restoring again in a few moments.

I have the Snapshot from the old site uploaded to DropBox, and could not get it to work.

  • Leonidas

    Hello there Ben ,

    I hope you're having a great day :slight_smile:

    I've been investigating into your reported issue and have to report the following:

    I downloaded the backup you are trying to migrate, uploaded it to the uploads/snapshots folder of my own local site and tried to import it. The import was successful and I was greeted with

    Success: Archive imported successfully

    This gives us valuable feedback about the root of your issue and directs us to look into the destination site' server, as it seems to be specific to that setup. What I'm going to do next is, have a deeper look into the server setup and keep you posted about it.

    Best regards,
    Leonidas

  • Ben

    Thanks Leonidas. I appreciate the update very much and am passing it on to my client.

    The import side is a test environment at SiteGround. I set up the OHStransition WordPress install for this test, with the theme and plugins from the original site all in place.

    In case it helps, there is nothing else of importance in the SiteGround account, the primary domain is awaiting a future project.

    Thanks,
    Ben

  • Leonidas

    Hi Ben ,

    I tried today to import the snapshot at your test environment and it worked. So, as of today you have a Snapshot there, ready to be restored following the steps of the article you mentioned.

    The steps I followed for the import process were these:
    - I downloaded the snapshot from the original site.
    - I uploaded it via cPanel to the uploads/snapshots folder of the second site.
    - I ran the import via the Snapshot->Import screen in the second site's wp-admin.

    I'm not really sure why the import was failing when you tried it, but because we used the same backup and my import worked whereas yours failed, I'm thinking there may had been some kind of file corruption somewhere between your download and upload of the file.

    Best regards,
    Leonidas

  • Ben

    Thanks Leonidas. I was able to run the Restore process on this file and am working through verifying the restored site.

    I have run into an issue with this. User tables were not restored, though they are there in the Snapshot. (wp_usermeta.sql and wp_users.sql)

    This is essential, since there are 7 admins, some with their usernames as creators of specific types of posts, and 109 "Subscribers," which in fact are the accounts created by members of the site community (a non-profit weavers and spinners guild) as they logged in for various purposes, especially paying for a membership or other item using Easy Digital Downloads.

    It appears I will need more help to make the Restore process complete.

    Thanks,
    Ben

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.