Snapshot installed snapshot and left for work came back i get 500 server error

I'm getting a 500 server error on my site after i installed snapshop pro. I configed it and then left for work. please advise.

  • Vaughan
    • Support/SLS MockingJay

    Hi Tony,

    As this is intermittent, it's difficult to debug.

    Could you possibly enable snapshot again and wait for the 500 error to appear, as soon as the 500 appears again, could you via FTP, copy/paste your .htaccess file here so we can take a look? only when the error 500 appears?

    I have a hunch, but it could be just a shot in the dark.

    There should be some error logs in your servers CPanel, hopefully they might show an error that caused the 500.

    Thanks

  • Tony
    • Syntax Hero

    there are copies of it that gets changed in the domain root to look at. This is the one that works.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    This is the one it changes to

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RRewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    see the differences?

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    Yes, there's a random R in the RewriteRule. This is the hunch I was thinking of.

    Unfortunately, I do not know what causes this.

    A few users had this issue with marketpress (including myself)

    except with MP, it would add a random S to the end of the htaccess

    A quick solution is to CHMOD your htaccess to 444 (read only) (be aware, sometimes you can only set 444 from your CPanel filemanager, not via FTP, it might says changed, but if you refresh you would see it's returned back to 644)

    This prevents the htaccess being changed then.

    I'm going to flag one of our SLS guys for some assistance with this, So he can possibly take a look at your server config, and then hopefully he might be able to figure out why DM seems to do this. It's not an easy bug to find or fix as it doesn't affect everybody.

    Hope this helps

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    Yes it's a very odd issue. with luck though, you might end up with the whole alphabet :wink: just kidding.

    Hopefully the dev will get to the bottom of it, but if you wish to prevent it in the meantime, just set the permission of htaccess to read only, that should prevent it happening. it's a workaround for now.

    Cheers.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.