Snapshot is failing and loading a 404

Snapshot is failing and loading a 404 from the site in a section of the screen above the log output.

I also tried adding the following:
define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
define('SNAPSHOT_FILESET_CHUNK_SIZE', 10); //default is (250);
define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100); //(default is 1000);

  • Nazmul H. Rupok

    Hi there,

    I hope you are doing great today and thank you for contacting us. I am sorry that Snapshot backups are not working well for you. Is it happening for manual snapshot or scheduled backup?

    Please allow support access so we can have a closer look at this on your end.
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please respond in this thread once access is granted. If you already did it, mention your URL.

    For the time being, please do the following for me which is a major steps (ignore what you already did) towards resolving the issue:

    1. Enable debug logging. You can do this by adding the following lines to your 'wp-config.php' file:

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    2. Increase WordPress memory limit:

    define( 'WP_MEMORY_LIMIT', '256M' );

    3. Add the following lines which are specific to Snapshot settings:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);

    4. Increase max execution time to 300 or more by trying the following methods.
    a. Create or edit php.ini in your website's root and add the following line:
    max_execution_time 300

    b. In .htaccess add the following line:
    php_value max_execution_time 300

    c. in cPanel you can go to "Software > MultiPHP INI Editor", choose your domain and PHP version and change the value for max_execution_time to 300 or more

    After that you can try Snapshot again, please try to set it to "Daily" so that we can have results soon for the Scheduled Backups, you can change later.

    Let me know how it goes.

    Best regards,
    Nazmul

  • Damo

    Hello,

    Access was granted yesterday during live chat and is still active. The domain is marken.com.au

    I had tried all the steps except enabling the WP debugging. Once I did that only one entry appeared in debug.log

    [20-Jun-2017 21:25:32 UTC] PHP Notice: Undefined index: action in /home/damian/public_html/wp-content/plugins/snapshot/lib/Snapshot/Controller/Full/Admin.php on line 82

    This had been working up until the last upgrade to Snapshot.

  • Nazmul H. Rupok

    Hi Damo

    Hope you are doing great. It seems getting stuck on the file backup :

    Since there is nothing on log, not sure what's causing the issue. We have seen some issue with the latest version of Snapshot but didn't face such issue on any setup. Would you roll back to previous version for now? You can click on changelog and download any version from here - https://premium.wpmudev.org/project/snapshot/

    Let's see if the older version works fine. If it works, please use this for now and hopefully it will be stable on next couple of releases.

    Have a nice day. Cheers!
    Nazmul

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.