Snapshot is Failing to Send Back-Ups to Amazon S3

Hi Guys,

I notice that my Snapshot Plugin is no longer sending my Back-Ups to S3.

I found this link of someone with the same problem and have gone through all the steps but none of them solved the issue : https://premium.wpmudev.org/forums/topic/snapshots-fails-to-send-files-to-s3

I can't figure out what the problem is...

Can you help me please?

Thanks,

Noel.

  • Rupok
    • Support Ninja

    Hi Noel

    I hope you had a wonderful day.

    Have you tried disabling all other plugins to make sure that some other plugin is not causing this? I tried to regenerate the issue in my test environment but could not regenerate it. It seems like the user solved it by the following two steps:

    "I generated a new access keypair within Amazon.
    In Snapshots I edited the destination using the new keypair."

    Can you please confirm that you tried it and still it doesn't work? If it still doesn't work, I need to check it in your site as I could not regenerate it at my end.

    Would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!
    Rupok

  • Noel
    • New Recruit

    Hi Rupok,

    Yes, I deactivated all plugins, tried to resend the back-up to S3 and it failed to send.

    It had been working fine for over a year but as you'll see when you log into my site, every back-up since 0ct 12th has failed to send to S3. Which is strange because nothing has changed on that site since then (no new plugins or themes)

    I tried what that other user suggested about the new Amazon Keys but that didn't fix it either.

    And yes, there is support access to my site so please feel free to log-in and have a look about.

    Thanks for your help,

    Noel.

  • Kasia Swiderska
    • Support nomad

    Hello Noel,

    Can you grant access again, it looks like this one is off. Also please enable debug mode in your WordPress. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    kind regards,
    Kasia

  • Noel
    • New Recruit

    Hi Kasia,

    I generated new access keys within Amazon and the 403 Error for sending the file remained the same.

    I tried this last week before I submitted my ticket, it didn't work then either.

    What do you think the problem is? Has Amazon changed something and the Snapshot integration now needs to be updated? (I'm just guessing here...)

    Cheers,

    Noel.

  • Noel
    • New Recruit

    Hi Kasia,

    Can you give me a direct link please? I've been googling for this and I'm only finding coding pages for developers.

    Also, when you click the Select Bucket button to see if it will pull up the other buckets on S3 it now gives this error message : "Error: Could not list buckets :The difference between the request time and the current time is too large."

    Does that help point you in the right direction on what's happening here?

    Thanks

  • Rupok
    • Support Ninja

    Hi Noel

    I hope you had a wonderful day.

    I just searched for other users complaining the same and found that most of the times, they resolved the 403 error by regenerating access keypairs in Amazon. But as this doesn't solve your issue, would you mind allowing support access once again so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I'm looking forward to hear from you and solve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi Noel

    I hope you had a wonderful day.

    Thanks for granting Support Access. I just logged in and found that the connection to AWS is giving 403 error and that's why your backups are not going to Amazon S3. So for finding the reason behind 403 error, I searched and found this Error Response list from Amazon:

    http://docs.aws.amazon.com/AmazonS3/latest/API/ErrorResponses.html

    From that list, it seems like most of the cases, this error occurs due to wrong keys or access to server issue like "Access Denied", "There is a problem with your AWS account that prevents the operation from completing successfully", "The AWS access key Id you provided does not exist in our records", "All access to this object has been disabled" etc.

    They are also suggesting to contact them here (http://aws.amazon.com/contact-us/) if you have this issue. So I'll also suggest you to contact with them first and make sure, there is no more problem from their end. As we could not regenerate the issue from our end, so it's not a bug of our plugin.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.