Snapshot is not CDing into the remote Dir using SFTP

Snapshot is uploading, but the files are 'landing' in the root directory.

Here is the relevant bit from the log:

2016-04-22 12:32:05: Login success.
2016-04-22 12:32:09: Home/Root: /home/wordpressBackup/
2016-04-22 12:32:09: Changing Directory: /home/wordpressBackup/intl
2016-04-22 12:32:09: sFTP: Failed to MKDIR: /home/wordpressBackup/intl
2016-04-22 12:32:09: PUT file success:

I have tried logging into the remote dir from the shell with the same user and I am able to CD, and even MKDIR. Additionally I have changed the wordpressBackup home folder to 777 and applied that to all sub folders and files. Lastly I made sure that the user and group are set to wordpressBackup.

I've started logging the SFTP daemon at debug level on the destination server.
Here is a snippet from the log.

Apr 22 12:30:43 site sftp-server[27958]: session opened for local user wordpressBackup from [192.145.239.34]
Apr 22 12:30:43 site sftp-server[27958]: received client version 3
Apr 22 12:30:44 site sftp-server[27958]: realpath "."
Apr 22 12:30:44 site sftp-server[27958]: open "/home/wordpressBackup/snapshot-1461278816-160422-191550-8241a8b9.zip" flags WRITE,CREATE,TRUNCATE mode 0666
Apr 22 12:30:44 site sftp-server[27958]: sent status Success
many more lines 'sent status Success'

One other thing I tried was removing the 'intl' directory on the chance that the plugin needed to create the dir, but it made no difference. I also tried using both relative and absolute paths for the remote dir, with and without the trailing slash. Still the same result.
I'm left wondering what else I can do to track this issue down.....

  • Adam Czajczyk

    Hello Steve,

    I hope you're well today and thank you for your question!

    The Snapshot Pro plugin does support sFTP and should be able to properly upload the files to the specified destination. The destination folder must already exist on a server (so removing "intl" would not help) and otherwise the files would be put into the.... root folder of the destination server.

    Let's start with this: please go to the "Snapshots -> Destinations -> [Edit your sFTP destination]" and make sure that the "Remote Path" option field is not empty and includes the path to /intl folder on destination server. Then make sure that in settings for particular Snapshot the "Directory (optional)" filed is empty.

    If this doesn't work still, let me know please and it would be great if you could grant me a support access to your site so I could take a closer look and check its settings. Here's a guide on how to do this:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam