Snapshot is not working

Snapshot is set once daily to take backup of bdnews to Google drive.But I just noticed that it it not take any backup after June 7 2016.Ivan
I have enabled the support access to check it out

Thanks
Monsur

  • Kasia Swiderska

    Hello Abu,

    Please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart). Try to create snapshot manually.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If it fails, please enable debug log in WordPress. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it. I would need then to see contents of the debug.log file - so please paste it to the text file and attach to post.

    kind regards,
    Kasia

  • Adam Czajczyk

    Hello Monsur!

    I checked your site and I noticed that currently there's no db tables selected in snapshot settings. I'm not able why this happened but it prevents Snapshot from being run as at least one table must be selected.

    Please go to the "Snapshot -> All snapshots" page and edit the snapshot settings, making sure that some database tables are selected.

    Let me know please if that helped!

    Best regards,
    Adam

  • Ash

    Hello Abu Monsur

    I have checked and found out that to copy a file your server responding 405 error. This is becauseof either the file is corrupted or your server is not permitting to copy.

    Would you please talk to your host if they have any restriction? Or do you remember which file you have added recently? If so, maybe remove that file temporarily and check again?

    Have a good day!

    Cheers
    Ash

  • Nithin

    Hi Abu Monsur,

    Hope you are doing good today. :slight_smile:

    I checked your website, extensively, and it seems like the /plugins folder, and /media folders are the one causing this issue.

    I tried to increase the memory limit, and max_execution_time to the following values, by creating a php.ini file in your folder, but it doesn't seem to help.

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 180

    Either these folders are having big file size, or it could be the 405 Error, as mentioned by Ash, which is causing this. Please confirm the 405 issue with your host to rule this out.

    I have created a test 15 mins, scheduled snapshot, which excludes plugins, and media folder, and now the backup seems to working fine, and is now sending files to Google Drive.

    I then created, a new snapshot(Snapshot Gcal Test) which is set to work for Daily Once, and it should work accordingly.

    Current workaround would be that, you'll have to manually copy these folders using FTP, or you could try increasing the memory limit, and max_execution_time to a higher value as set by your host, and check whether it works.

    I hope this helps. Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.