Snapshot is not working

Create Snapshot task not completing. Whenever I tried to take backup it can't finish. How can I fix it?

  • Ari

    Hi Anil Kathuria,

    I have tried several times for creating snapshot, but every time it's failing after 76%. For debug purpose I have set few lines of code in the config.php.

    define('WP_MEMORY_LIMIT', '256M');
    define('WP_MEMORY_LIMIT', '256M');
    define('WP_MAX_MEMORY_LIMIT', '512M');
    
    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);
    
    @ini_set( 'display_errors', 0 );
    @ini_set( 'memory_limit', '256M' );
    @ini_set( 'max_execution_time', 600 );

    Abode code is used for increasing memory limit for both of server & WordPress, it also used for creating the debug.log file inside the wp-content for further investigation. But unfortunately I cloudn't find anything in the debug.log because it is failing by 404 not found error.

    For further investigation I need to do plugin test, if you are not familiar with plugin test, shortly it is temporarily deactivate all plugins except wpmudev dashboard & snapshot pro. then try to take snapshot, if it works then its clean that there is a plugin which is causing this issue, then I will activate plugin one by one & each time I will try to take snapshot so I can find that plugin.

    Here is the details article: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    Let me know is this test OK for you? if not please create a staging version of your site, so I can test there.

    -----

    In case, if you need more information for how to create staging environment.
    Usually there are 3 options:
    1) You can do that with hosting, if your hosting provide this feature.
    2) You can use tools like Duplicator, All-in-One WP Migration, also our Snapshot, but it is not working for you.
    3) You also can do that manually - here is a guidence to do so: http://www.wpexplorer.com/migrating-wordpress-website/

    -----

    Waiting for your response,
    Best Regards, Ari

  • Ari

    Hi Anil Kathuria,

    I need your FTP or cPanel details to perform the plugin test. Because I will deactivate the plugin by relocating them to another folder. In this way you will not loss any setting of plugins.

    So please send me the FTP or cPanel details, since it's our public forum, you have to send the credentials through our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question
    using the below template:

    Subject: "Attn: Ari"
    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password)
    - cPanel/Plesk credentials (host/username/password)
    - link back to this thread for reference (it is: https://premium.wpmudev.org/forums/topic/snapshot-is-not-working-3)
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Cheers, Ari

  • Ari

    Hi Anil Kathuria,

    I did lot of staff today with this problem, below is the report what I did and what I found.

    > Tried restoring with snapshot but they got failing.
    > Then I started counting the time when it's failing.
    > Every time it get failed when it start storing Files from upload, plugins & theme folder.
    > So I excluded media files & plugins, then i see spanshot get successful.
    > When start storing Files it's failing within 1:40 to 1:45 seconds.
    > Then I tried to make a backup with another plugin "Duplicator", but it also get fail with a white screen.
    > While tried with duplicator, I discovered another thing that spanshot keeps the snapshots file in the server, though I deleted them, they deleted from database logs but not deleted from the server. and It about 2GB in total size. I deleted these unnecessary files. But I will test it more, and contact with our devs about it.
    > Then again I tried with duplicator by exclude the snapshot files, but also failed with a white screen.
    > Then I thought to make a manual backup to try it in my local machine, So I started compress the whole website, but I see that it's not compressing, I tried twice with no luck, then I see a error "disk quota exceeded", hmm, then I check the disk from the cPanel, I found that it have only 5GB space, which is very low space. I think it's the main problem for other errors, and that's why we get 404 errors with no logs in the error.log file.

    Anyway, please contact with your hosting provider to increase the disk size, you have only 5GB space, it's really very low space.

    Also I have found another file which is very large about 1.53 GB in public_html/wp-content/ai1wm-backups, if you think it is not a important file, please remove it too.

    After remove this file or inrease the Disk space, please contact to me again here.

    Regards, Ari

  • Anil Kathuria

    Hi Ari,

    I cleaned up everything on the account. Removed any extra files, folders sitting there. Removed any unwanted plugins etc.

    Total space used on the account right now is 919MB of 5GB. So only 18% of the available space is being used. That should be enough space available for backup process.

    As an additional house keeping step. I deactivated and deleted Snapshot Pro plugin and reinstalled it from scratch. Added Dropbox as the destination.

    It still fails when I try to take a complete Snapshot.

    What is needed to make this work? The site is not a huge site. I have several updates pending on it and I am waiting to get a complete backup before I do any updates.

    I really need this working.

    Thanks
    Anil

  • Ari

    Hi Anil Kathuria,

    About the error log, this is just "notice", it doesn't cause any issue.

    I have tried a lot in many ways with lot of troubleshooting, and it seems the server get stuck, server can't process the request. I have also tried with other plugins, but same result! your server can't process the mid-range type requests.

    Please contact to your hosting, and say that:

    Server get stuck while run a backup task in my website, it gives me "wp-ajax.php" not found after some time.

    If they can't fix this issue, probably I suggest you to change your hosting, and get a better one. You can check our blog post where you'll find a review on hostings:
    https://premium.wpmudev.org/blog/web-hosting-review-so-just-who-is-the-best/

    I probably suggest dreamhost.

    Anyway, You also can do a manual backup for your site. If you are interesting here is a guideline how to do it: http://www.wpexplorer.com/migrating-wordpress-website/

    If you have any question let me know here, Thanks!

    Best Regards, Ari

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.