Snapshot is not working. Getting error message!

Hi.

I tried taking a snapshot of Site A to then restore on Site B (basically moving the site), but at first I was getting an "empty" file when downloading it from a browser.

So I was instructed to retrieve the file manually, which I did via ftp. I imported it to Site B (the site selected in this ticket), and tried to restore -- but got the following attached error message.

I really need to move the site I've been working on to this new space (currently a basic WP install with just the theme and WPMUDEV installed) ASAP.

Can anyone PLEASE look into this and help me understand what's going wrong? I've granted support access to both sites, but can supply more info or ftp access if needed. PLEASE HELP!!
Thank you

  • Vaughan

    Hi anton,

    Can you check your server error logs, you should be able to find them in your CPanel, or look for an error_log file in your sites /wp-admin folder.

    This might shed some light on what's causing the error.

    I Think it could be related to your servers max_execution_time.

    If you have access to php.ini can you set max_execution_time to say 300?

    max_execution_time = 300

    You may need to ask your webhost how to do this on your server.

    Hope this helps

  • Anton

    @Vaughan

    OK, so I changed the max_execution_time to 300. Tried again with a new snapshot. Still getting same error message. Checked error_log. Didn't see anything from what I just did in there, but there is something from last night:

    [11-Nov-2015 18:04:05 UTC] PHP Warning: rmdir(/home/outincomics/public_html/wp-content/uploads/snapshots/_restore/www/wp-content/uploads/1969/12): Directory not empty in /home/outincomics/public_html/wp-content/plugins/snapshot/lib/Snapshot/Helper/Utility.php on line 996
    [11-Nov-2015 18:04:05 UTC] PHP Warning: rmdir(/home/outincomics/public_html/wp-content/uploads/snapshots/_restore/www/wp-content/uploads/1969): Directory not empty in /home/outincomics/public_html/wp-content/plugins/snapshot/lib/Snapshot/Helper/Utility.php on line 996
    [11-Nov-2015 18:04:05 UTC] PHP Warning: rmdir(/home/outincomics/public_html/wp-content/uploads/snapshots/_restore/www/wp-content/uploads): Directory not empty in /home/outincomics/public_html/wp-content/plugins/snapshot/lib/Snapshot/Helper/Utility.php on line 996
    [11-Nov-2015 18:04:05 UTC] PHP Warning: rmdir(/home/outincomics/public_html/wp-content/uploads/snapshots/_restore/www/wp-content): Directory not empty in /home/outincomics/public_html/wp-content/plugins/snapshot/lib/Snapshot/Helper/Utility.php on line 996
    [11-Nov-2015 18:04:05 UTC] PHP Warning: rmdir(/home/outincomics/public_html/wp-content/uploads/snapshots/_restore/www): Directory not empty in /home/outincomics/public_html/wp-content/plugins/snapshot/lib/Snapshot/Helper/Utility.php on line 996
    [11-Nov-2015 18:04:05 UTC] PHP Warning: rmdir(/home/outincomics/public_html/wp-content/uploads/snapshots/_restore): Directory not empty in /home/outincomics/public_html/wp-content/plugins/snapshot/lib/Snapshot/Helper/Utility.php on line 996

    I've been up all night trying to figure this out, but need to head to bed. I desperately need to get this site moved ASAP. If anyone can help me in figuring out what the problem is, I'd really appreciate it. Support access to both sites renewed. Let me know if FTP access is needed.

  • Vaughan

    Hi,

    Those error messages suggest that the script can't unlink the files, therefore when it tries to remove the actually temporary folder, the folder is not empty therefore rm command will not work.

    rm can only remove a folder that is empty, if the folder it's trying to remove contains any files then you will receive that error.

    check the permissions on the uploads/snapshots folder, make sure they are writeable. also check that the files in snapshots folder have the same owner/group.

    I notice on http://www.prismcomics.org/

    you have an imported file from another server, can I try and do a restore using that imported zip? I don't want to try without asking you first in case it takes the whole site down.

    Thanks

  • Anton

    @Vaughan -

    The snapshots folder seems to be writable for "owner" (but not "group" or "others" - does that matter?). The snapshot file itself within the folder doesn't have "execute" checked - is that a problem?

    Yes, prismcomics.org is where I'm trying to move the new site, using the snapshot from another server. There's no site there at the moment, so it going down isn't a problem. Please let me know ASAP when you're doing this, though! The site's not finished, and I have to continue working on it once it's moved -- but I can't do anything until that's done.

    Thanks!

  • Vaughan

    Hi,

    The chmod should be ok at 755 for folders and 644 for files. Execute isn't necessary & actually should be avoided for security :slight_smile:

    You can try changing to 777 just for testing. but ideally we should try to avoid 777 if possible.

    With regards to the error.

    I'm still seeing that max_execution_time is set to 120, which is why it's timing out causing the error. At least i'm 99% sure that's the reason.

    Thanks

  • Vaughan

    Hi,

    php.ini only affect the folder they are in, they do not recurse folders like htaccess do. But your php.ini file wasn't actually being loaded.

    I moved your php.ini file to your /public_html folder.

    Then I added the following lines to your htaccess

    <IfModule mod_suphp.c>
    suPHP_ConfigPath /home/vaughanm/public_html
    </IfModule>
    
    <Files php.ini>
    order allow,deny
    deny from all
    </Files>

    This tells your server to actually use the php.ini file from the path defined above.

    Now we have a different error though. Which i'm looking into.

  • Anton

    @Vaughan -

    Hi - just checking to see if there's any update?
    I'm at a weird spot here, as I'm waiting to see if you guys can hopefully restore from the snapshot that was imported. But at the same time, I need to continue working -- but working on the previous site would be a waste of time if you guys are successful with the snapshot, since any new work won't be reflected in that. So not sure what I should do...
    If you have any suggestions, or if you won't be working with the snapshot that's already imported, let me know!
    Thanks

  • Vaughan

    Hi,

    One thing you could try.

    On the other site, create another snapshot, but only backup the DB tables, do not include any files.

    Then import that snapshot to the new site and then try & restore.

    If that's successful. Then at least the DB will be up to date.

    Then you could manually, using FTP.

    Download your /wp-content folder from the old site to your PC.

    Then using FTP, upload the /wp-content folder onto the new site, that should then hopefully get you going.

    Worth a try anyway :slight_smile:

  • Anton

    @Vaughan -

    OK, so I tried to do a database-only snapshot/restore. Unlike the previous attempt, it actually STARTED to work, and got about halfway through all the tables, and then...this error message:

    An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings.

    So what's wrong with my settings that not even this is working??
    Time's really running out here -- so any help is greatly appreciated. Thanks

  • Anton

    @Vaughan -

    Since the database import was timing out with the error message about halfway through each time I tried, I decided to go through and prune some of the plugins I really didn't need. I also noticed some that I had deleted (like Buddypress, WooCommerce) had left behind their databases -- so I selected only the tables I needed and left the rest unchecked. It ended up being about half of what I had before, so....

    ....I tried one final time....and it worked!!

    Now I'm uploading the wp-content folder (which again, is taking several hours) overnight, and hopefully I'll wake up to my website restored in its new place.

    I wish I knew what the initial problem was. Snapshots Pro has never failed me before, but then again I never tried to a move a site this large either.

    I'll let you know if it's a success in the morning... :wink:

  • Anton

    @Vaughan -

    So the process worked...
    ...but certain plugins (when activated) crashed the site. I think its because I wasn't snapshot-ing all the databases. There was also stuff I had put in the original site's wp-config file (like defining something for the WPMUDEV POPUP plugin) that I didn't have in the new one, which caused errors. All easy to add and fix, but during the process I somehow accidentally copied the old wp-config to the new site (it was early this morning, and I had little sleep).

    Basically...since the last message, I've gone through the whole process a few times, and slowly learned what I was doing wrong each time and made sure I didn't repeat the mistake. All in all...I wasted a couple of days on this (and I was already quite behind). But....the site has been fully moved finally!!

    I'm hoping I don't encounter any weird errors going forward, but things appear to be running smoothly for the time being....

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.