snapshot issue

Hello,
I have have installed snapshot on a multisite kkr.co.il

I did not succeed snapshot'ing even once.

Is it possible to find what I missed while setting it up?

Thanks
David

The error reads as follows:

Warning: php_uname() has been disabled for security reasons in /home/idave147/domains/kkr.co.il/public_html/wp-content/plugins/snapshot/lib/destinations/aws/AWSSDKforPHP/sdk.class.php on line 120 Warning: php_uname() has been disabled for security reasons in /home/idave147/domains/kkr.co.il/public_html/wp-content/plugins/snapshot/lib/destinations/aws/AWSSDKforPHP/sdk.class.php on line 120 Warning: php_uname() has been disabled for security reasons in /home/idave147/domains/kkr.co.il/public_html/wp-content/plugins/snapshot/lib/destinations/aws/AWSSDKforPHP/sdk.class.php on line 120 {"errorStatus":false,"errorText":"","responseText":"Init Start","table_data":[{"table_name":"wp_blog_versions","rows_total":0,"segment_idx":1,"segment_total":1,"rows_start":0,"rows_end":0},{"rows_start":0,"rows_end":1,"table_name":"wp_blogs","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":0,"table_name":"wp_commentmeta","rows_total":0,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_comments","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":0,"table_name":"wp_links","rows_total":0,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":163,"table_name":"wp_options","rows_total":163,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":2,"table_name":"wp_postmeta","rows_total":2,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":4,"table_name":"wp_posts","rows_total":4,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":0,"table_name":"wp_registration_log","rows_total":0,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":0,"table_name":"wp_signups","rows_total":0,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_site","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":64,"table_name":"wp_sitemeta","rows_total":64,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_term_relationships","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_term_taxonomy","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_terms","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":19,"table_name":"wp_usermeta","rows_total":19,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_users","rows_total":1,"segment_idx":1,"segment_total":1}],"files_data":["plugins","plugins\/akismet","plugins\/another-wordpress-classifieds-plugin","plugins\/business-directory-plugin","plugins\/diamond-multisite-widgets","plugins\/network-shared-posts","plugins\/regenerate-thumbnails","plugins\/snapshot","plugins\/tag-groups","plugins\/threewp-broadcast","plugins\/wpmudev-updates","plugins\/wunderground","plugins\/xili-tidy-tags","plugins\/yet-another-related-posts-plugin","themes","themes\/glamour","themes\/twentyeleven","themes\/twentytwelve"],"MEMORY":{"memory_limit":"128M","memory_usage_current":"33.25M","memory_usage_peak":"33.5M"}}

  • idave147

    Hi Joe,

    Thanks for your reply. I checked and it was PclZip that was activated.

    I just activated ZipArchive instead and received the error message I copied/pasted below, which I hope will give you a clue as to what I did wrong.

    As for your comment to the same post here:

    Thank you for reporting this a second time but it will certainly not help resolve it any faster and you have indeed denied the addressing of someone elses issue from being addressed by submitting duplicate posts:
    https://premium.wpmudev.org/forums/topic/snapshot-issue

    Please refrain from this practice which only clogs up the ticket system and denies others service.

    Clicking "Send Post" started a process saying something like "Sending post" with a progress bar that turned on and on never ending. I saw no confirmation of the kind "message received" and I was pretty sure my message never left my browser.
    Having this bug fixed will surely save your time and mine and no less, "a good word" like the one you sent.

    All the best

    Warning: php_uname() has been disabled for security reasons in /home/idave147/domains/kkr.co.il/public_html/wp-content/plugins/snapshot/lib/destinations/aws/AWSSDKforPHP/sdk.class.php on line 120 Warning: php_uname() has been disabled for security reasons in /home/idave147/domains/kkr.co.il/public_html/wp-content/plugins/snapshot/lib/destinations/aws/AWSSDKforPHP/sdk.class.php on line 120 Warning: php_uname() has been disabled for security reasons in /home/idave147/domains/kkr.co.il/public_html/wp-content/plugins/snapshot/lib/destinations/aws/AWSSDKforPHP/sdk.class.php on line 120 {"errorStatus":false,"errorText":"","responseText":"Init Start","table_data":[{"table_name":"wp_blog_versions","rows_total":0,"segment_idx":1,"segment_total":1,"rows_start":0,"rows_end":0},{"rows_start":0,"rows_end":1,"table_name":"wp_blogs","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":0,"table_name":"wp_commentmeta","rows_total":0,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_comments","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":0,"table_name":"wp_links","rows_total":0,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":163,"table_name":"wp_options","rows_total":163,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":2,"table_name":"wp_postmeta","rows_total":2,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":4,"table_name":"wp_posts","rows_total":4,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":0,"table_name":"wp_registration_log","rows_total":0,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":0,"table_name":"wp_signups","rows_total":0,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_site","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":64,"table_name":"wp_sitemeta","rows_total":64,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_term_relationships","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_term_taxonomy","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_terms","rows_total":1,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":20,"table_name":"wp_usermeta","rows_total":20,"segment_idx":1,"segment_total":1},{"rows_start":0,"rows_end":1,"table_name":"wp_users","rows_total":1,"segment_idx":1,"segment_total":1}],"files_data":["plugins","plugins\/akismet","plugins\/another-wordpress-classifieds-plugin","plugins\/business-directory-plugin","plugins\/diamond-multisite-widgets","plugins\/network-shared-posts","plugins\/regenerate-thumbnails","plugins\/snapshot","plugins\/tag-groups","plugins\/threewp-broadcast","plugins\/wpmudev-updates","plugins\/wunderground","plugins\/xili-tidy-tags","plugins\/yet-another-related-posts-plugin","themes","themes\/glamour","themes\/twentyeleven","themes\/twentytwelve"],"MEMORY":{"memory_limit":"128M","memory_usage_current":"32.25M","memory_usage_peak":"32.5M"}}

  • Paul

    @idave147,

    Jumping in on this thread. The key is the first line of the Warning

    Warning: php_uname() has been disabled for security reasons in /home/idave147/domains/kkr.co.il/public_html/wp-content/plugins/snapshot/lib/destinations/aws/AWSSDKforPHP/sdk.class.php on line 120

    This issue is similar to a previous thread. https://premium.wpmudev.org/forums/topic/snapshot-aws-error

    Basically the issue is the AWS Library used by Snapshot uses a standard PHP function 'php_uname()' which has been turned off by your hosting because they see it as a security concern. There is not much we can do with this at the moment since the library is provided by Amazon and the only solution for connecting to AWS.

    So I'm reposting my solutions from that thread to this one.

    So to solve this you have a couple of solutions.

    1. Follow the excellent advice from Patrick on enabling php_uname in your php.ini. But I'm guessing you hosting will prevent this. I've seen some hosts compile a special PHP build so the php.ini has no effect.

    2. I noticed this is a Warning. Which tells me you have your error_reporting set such that warnings are displayed to the screen. So I find it funny that a hosting company would turn off php_uname but allow error_reporting for warnings. Hack error_reporting can provide all sorts of savory information about the hosting. More than php_uname would in fact. So best thing is to turn off error_reporting. First check your WP_DEBUG in your site's wp_config.php http://codex.wordpress.org/Editing_wp-config.php#Debug Also you want to double check your php.ini (if available to you) and make sure error_reporting ( http://php.net/manual/en/function.error-reporting.php) and display_errors ( http://www.php.net/manual/en/errorfunc.configuration.php#ini.display-errors ) is set such that warnings and notices are NOT displayed.

    3. If all this fails then what I would do is edit the functions.php file of my current theme. In the functions.php just add a stub function to sort of trick the AWS library that it has a valid function. Something like

    if (!function_exists('php_uname')) {
       function php_uname() {
          return false;
       }
    }
  • aecnu

    Greetings David,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.