SnapShot issues with re-installation

Snapshot’s been deactivated for some reason on this website and fails to instal again. I’ve deleted the plugin files from my server, which seems to work in most cases (10 websites afflicted, see:; however, in this case, even after the plugin files have been deleted, the installation still fails.

This is the message I get:

Server error status: Internal Server Error [500]

I’ve enabled support access in wordpress.

Hope to hear from you soon.

Kind Regards,

Dubie Bacino

  • Nithin
    • Support Wizard

    Hi Dubie,

    Hope you are doing good today. :slight_smile:

    I’m afraid, support access to website is no longer active. 500 server error is generic, and it could relate to many factors causing it.

    To have a better idea regarding what’s causing this could you please enable debug mode, so that we could see what exactly is causing this.

    To enable debug mode, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    define( 'SCRIPT_DEBUG', true );

    After making the above changes, please try to re-install Snapshot. Once the issue ocurs, the related errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Please let us know how that goes, have a great weekend. :slight_smile:

    Kind Regards,


  • Dubie
    • Free Atom

    Hi Nithin,

    Thanks for your reply.

    I modified the wp-config.php file as per your instructions:

    Then I tried to reinstall SnapShot and after it failed, I looked for the debug.log file inside the /wp-content/ directory. I could not find it. I again attempted to instal SnapShot both from wordpress and from the hub, failed both times, then again looked for the debug.log. I reloaded the file manager to make sure, but the file isn't there.

    [image pos="1"]

    Any thoughts?


  • Dubie
    • Free Atom


    I repeated the installation in the hub and after it failed, I went into wordpress dashboard to try to do it again from there. However the plugin there was showing as installed, so I tried to activate it. The activation failed. This time I finally found the debug.log. Here it is:

    [03-Mar-2019 14:40:35 UTC] WPMU DEV Upgrader error: INS.01 – Already installed.

    [03-Mar-2019 14:40:45 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 524288 bytes) in /home5/liveonskill/public_html/wp-includes/SimplePie/Item.php on line 2815

    [03-Mar-2019 14:40:58 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 65536 bytes) in /home5/liveonskill/public_html/wp-content/plugins/snapshot/lib/Snapshot/Helper/Privacy.php on line 11

    [03-Mar-2019 14:40:58 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 65536 bytes) in /home5/liveonskill/public_html/wp-includes/class-wp-hook.php on line 286

    Hope this helps.



  • Kris
    • Support

    Hi Dubie

    Those errors from debug.log tell us that your memory limit is to low.

    I check you site which is included in this thread and memory_limit is 256M.

    Are you able to increase this on host side to 512M or 768M and see if this help?

    Or add this line on wp-config.php file:

    define('WP_MEMORY_LIMIT', '512M');

    Those defines should be placed above the “/* That’s all, stop editing! Happy blogging. */”

    This is also related to your other site from this thread which have same low value:

    Kind Regards,


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.