Snapshot managed backup gives 404 admin-ajax error.

When I try to make a snapshot backup, it gives me 404 admin-ajax.php error in the browser console.

  • Kasia Swiderska
    • Support nomad

    Hello Tim ,

    I'm very sorry that our plugin is not working correctly on your site.

    Very often this issue is caused by the I/O Usage hitting 100% - if you have access to cPanel, can you run Managed Backup and check the I/O usage levels?
    If you don't have access to cPanel (or any other panel that allows checking the I/O Usage) can you contact your hosting provider and ask if they can check any high levels for that?

    kind regards,
    Kasia

  • Tim
    • New Recruit

    Hi Kasia Swiderska ,

    First of all sorry for my very late response. It has been quite hard to find out the I/O levels at the webhost. In the end I didn't even get a final answer from them.

    Just to verify: what happens is that the backup is starting but then after some time the error happens. Is there any way around this besides changing to a different hosting provider?

    Kind regards,
    Tim

  • Rupok
    • Support Ninja

    Hi Tim,

    So sorry to hear the inconvenience you are having. Can you please try adding the following lines in your wp-config.php file and save and then try to create another backup again? You should get your wp-config.php file at the root directory for your domain in your hosting.

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 20);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600); //100MB
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_BACKTRACE_ALL', true);
    define('SNAPSHOT_SYSTEM_DEBUG_OUTPUT', true);

    Please note, this will make the file and database table chunks smaller. So it might take longer than usual.

    Let us know the result. If it fails again, please provide the debug.log file from the "wp-content" directory. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Regards,
    Rupok

  • Rupok
    • Support Ninja

    Hi Tim,

    I apologize for not sending details about how to enable debug mode in my previous reply. Without the debug mode enabled, the debug.log file won't be generated. Can you turn on debug mode in WordPress before trying the next backup? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case, the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If the file is very long, paste them to a text file and attach with your reply.

    Regards,
    Rupok

  • Tim
    • New Recruit

    Hi Rupok

    I've managed to make another backup which failed again. Now I do have the log:

    [06-Jun-2019 16:32:48 UTC]
    [06-Jun-2019 17:24:54 UTC] PHP Warning: getimagesize(https://dummyurl.com/wp-content/uploads/2018/10/IG-post2-150x150.png): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
    in /var/www/htdocs/wp-content/plugins/wp-smush-pro/core/modules/class-wp-smush-cdn.php on line 1012
    [06-Jun-2019 17:24:54 UTC] PHP Warning: A non-numeric value encountered in /var/www/htdocs/wp-content/plugins/wp-smush-pro/core/modules/class-wp-smush-cdn.php on line 908
    [06-Jun-2019 19:17:43 UTC] PHP Notice: session_start(): ps_files_cleanup_dir: opendir(/var/lib/php/session) failed: Permission denied (13) in /var/www/htdocs/wp-content/plugins/unyson/framework/includes/hooks.php on line 258
    [06-Jun-2019 19:17:49 UTC]

    For privacy reasons I have changed the url in above log.

    I don't really see any real errors which point me in the right direction.

    Regards,
    Tim

  • Patrick Freitas
    • Staff

    Hi Tim

    Hope you are doing well.

    Thank you for the Logs,

    They are only notices and warning, shouldn't stop the backup.

    I made some new tests on Snapshot and found that it was stopping on the wp-content/uploads/fw-backup

    I added this folder on the exclusion list and made a new Managed Backup.

    It is working fine now.

    Let us know if you need any further help on this.
    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.