Snapshot Managed Backup Import Not Working

I'm trying to restore a website (anthroposophybayarea.org) from a managed backup using Snapshot. I've tried following the directions I found in the community, creating a new wordpress install, moving the backup archive into the snapshots folder, importing it, but it still doesn't show up in the "all snapshots" list. This website has been down for almost two weeks because what should be simple is not working at all.

I had to migrate the site, so I backed it up before I moved it, then the migration didn't work right so I had to do a fresh wordpress install, which is why I'm trying to restore from the snapshot managed backup file. I'm using siteground hosting, if that matters.

When I did the fresh wordpress install, I got rid of the www in front of the url and now I have both http://www.anthroposophybayarea.org and anthroposophybayarea.org listed in my Hub. Would that really cause this much trouble though?

There was enough theme customization (that someone else did) that I don't want to have to rebuild this site completely from scratch.

  • Dimitris

    Hey there Arianna,

    hope you're doing good and thanks for reaching us!

    First of all, I'd like to mention the difference between Snapshots and Managed Backups.

    The first, can be used to backup your website (choose which subsite in case of multisite, choose files and DB tables you want to backup) and it can also "pushed" to another server via FTP or a Dropbox or Google Drive folder.
    The restoration process, is similar with the one you've mentioned and it's been further explained in this article from our blog: https://premium.wpmudev.org/blog/backup-with-snapshot/
    (just keep in mind that screenshots in this article are covering previous UI of Snapshot, but all necessary settings are still in place)

    On the other hand there are Managed Backups. These are backing up the whole installation (even if it's a multisite installation) and saving it in our own WPMUDEV cloud servers.
    The restoration process is completely different and includes a .zip file and an installer PHP script that's handling the whole migration process. You can find detailed information on how to do so in next post from our blog, under the "And When it Comes to Restoring, Oh My!" subtitle.
    https://premium.wpmudev.org/blog/introducing-managed-wordpress-cloud-backups-for-free/

    Your WPMUDEV membership comes with 10GB of free cloud storage for the total of your connected websites, but you can even raise this up by acquiring some additional storage. More details on this can be found here: https://premium.wpmudev.org/blog/introducing-backup-storage-plans/

    Finally, here's a blog post on how to restore from Snapshot (using either good-old Snapshots or Managed Backups) in case your website is inaccessible.
    https://premium.wpmudev.org/blog/restore-wordpress-backup-snapshot/

    Having said all that, as you've mentioned managed backups, you should go to Hub/My Websites page, select your website, click on Backups tab and then on the little cloud icon of your latest backup.

    Then follow the instructions as stated in next popup window.

    Hope that was some help, let us know if further assistance is required here!
    Warm regards,
    Dimitris

  • Arianna

    What exactly does "upload to the webroot of your server as instructed" mean? There are no instructions for that. I thought I did that before, but clearly since it isn't working, I didn't put the files in the right place.

    I'm getting really frustrated, because my host support doesn't know what I'm trying to do and isn't being helpful and your instructions documentation is extremely hard to find and unclear.

  • Arianna

    Finally got the wizard to work. For future reference, you need to tell people that the database is not the website file database, it's the mySQL database (which has a weird name) and that the username etc. is for that database, not for the FTP/SSH of their hosting account. So you have to talk to your hosting ppl to figure out how to get (or set) the correct login credentials for that database. Knowing that instead of having to figure it out by trial and error would have saved me a TON of time.

    The website seems to be up, but I can't access the admin panel. Also, I'm getting the below notices above the header on every page (they're actually showing up, which is a problem). These are the same notices that show up on the wordpress admin page instead of the login. How do I fix this?

    Strict Standards: Redefining already defined constructor for class Wdcp_Model in /home/ngls5235/public_html/anthroposophybayarea.org/wp-content/plugins/comments-plus/lib/class_wdcp_model.php on line 13

    Strict Standards: Redefining already defined constructor for class Wdcp_CommentsWorker in /home/ngls5235/public_html/anthroposophybayarea.org/wp-content/plugins/comments-plus/lib/class_wdcp_comments_worker.php on line 9

    Strict Standards: Redefining already defined constructor for class Wdcp_PublicPages in /home/ngls5235/public_html/anthroposophybayarea.org/wp-content/plugins/comments-plus/lib/class_wdcp_public_pages.php on line 12

    Strict Standards: Non-static method Wdcp_PublicPages::serve() should not be called statically in /home/ngls5235/public_html/anthroposophybayarea.org/wp-content/plugins/comments-plus/comments-plus.php on line 101

    Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/ngls5235/public_html/anthroposophybayarea.org/wp-content/plugins/comments-plus/lib/class_wdcp_model.php:13) in /home/ngls5235/public_html/anthroposophybayarea.org/wp-content/plugins/comments-plus/lib/external/facebook/facebook.php on line 49

    Warning: Cannot modify header information - headers already sent by (output started at /home/ngls5235/public_html/anthroposophybayarea.org/wp-content/plugins/comments-plus/lib/class_wdcp_model.php:13) in /home/ngls5235/public_html/anthroposophybayarea.org/wp-content/plugins/membership/app/controller/class-ms-controller-plugin.php on line 99

    WordPress database error: [Table 'ngls5235_917.wp_anthroreports_post_activity' doesn't exist]
    DELETE FROM wp_anthroreports_post_activity WHERE post_ID = 764 AND blog_ID = 1

    Notice: Trying to get property of non-object in /home/ngls5235/public_html/anthroposophybayarea.org/wp-content/plugins/w3-total-cache/PgCache_Flush.php on line 62

  • Chris

    In all honesty I purchased a Premium Subscription to WPMU Dev simply because of DEFENDER & SNAPSHOT, but I have to admit that I'm pretty disappointed with the ability to IMPORT/MIGRATE.

    I assumed that it would be a great alternative to All-in-One WP Migration (which I paid for the Pro version for single site), but it was going to be another $199 for the Multi-site edition, and thought well since I'm already paying for WPMU Dev might as well get the most out of it.

    Being technically savvy, I was working on a local install of a WordPress mult-site, I wanted to download and install all the WPMU Dev plugins in order to test them, and allow my partner to easily test them. I created an instance on Google Cloud, and figured "aight, take a backup of my local WP installation, download it, upload it to the new Google Cloud install, and then import/restore..... One would assume it should have been that quick & easy, but it was not.

    I got the following error message(s):

    Importing archives from: /opt/bitnami/apps/wordpress/htdocs/wp-content/uploads/snapshots/
    Processing archive: snapshot-1498991801-full-bbb3ddd2.zip (121.41 MB)
    Error: Manifest data does not contain ITEM section.
    Processing archive: snapshot-1499100754-170703-165234-cb118305.zip (18.51 MB)
    Success: already present. not importing.
    Oh no! One or more of your Snapshot archives was not imported successfully. Please check your Snapshot logs for more details, or try restoring again in a few moments.

    I do see LOTS of value in WPMU-Dev: all the plugins available, the cloud backup, chat support, etc. .... but I must admit, I was hoping to have a quicker/easier time of migrating/restoring with Snapshot; I was expecting a similar experience to that of the All-in-One WP Migration plugin.

    Hopefully somebody can get back to me with how to easily migrate my site, as of now I am using WinSCP to copy off the plugins folder from the local install to the Google Cloud install.