Snapshot managed backup is not working

Trying to use managed backup feature but it seems it never went well for me. Talking to live chat, I was suggested to increase my memory limit to 512M and now I am getting the following error:

Aw shucks, something went wrong Instead of the beautiful response we expected, we got this:<empty response>

It was set to 256M before. And by then, the following is from Snapshot's log:

[Cron][2017-04-25 07:49:19][Info] Processing backup
[Cron][2017-04-25 07:49:19][Info] Processing backup
[snapshot][2017-04-25 07:49:19][Info] We have an offending error: backup
[Queue][2017-04-25 07:49:19][Notice] Fetching table ******_postmeta (chunk 15)
[snapshot][2017-04-25 07:49:19][Info] Successfully processed backup files chunk
[Cron][2017-04-25 07:49:19][Info] Next process kickstart action scheduled for Tue, 25 Apr 2017 07:54:19 +0000
[Cron][2017-04-25 07:49:46][Error] Error processing automatic backup: backup
[Cron][2017-04-25 07:49:46][Notice] General backup error
[Cron][2017-04-25 07:49:47][Info] Processing backup
[Cron][2017-04-25 07:49:47][Info] Next process kickstart action scheduled for Tue, 25 Apr 2017 07:54:47 +0000
[Cron][2017-04-25 07:49:47][Info] Processing backup
[snapshot][2017-04-25 07:49:47][Info] We have an offending error: backup
[Cron][2017-04-25 07:49:47][Error] Error processing automatic backup: backup
[Cron][2017-04-25 07:49:47][Notice] General backup error
[Remote][2017-04-25 16:13:56][Info] Initiate token exchange
[Remote][2017-04-25 16:13:57][Info] Successful remote response for get-token
[Remote][2017-04-25 16:13:57][Info] Update token with remote response
[Remote][2017-04-25 16:13:58][Info] Successful remote response for credentials

I have also noticed, Server I/O is maxed out while backing up, RAM and CPU are fine, RAM usage is below 128MB and I have 17 plugins active.

Any help is appreciated.