Snapshot Managed Backup not working

Snapshot Managed Backup not working, and throwing the following error:

Increase Memory_limit to 512M, max_execution_time to 600, and also excluded many big files but the issue still exists.

  • Nithin
    • Support Wizard

    Hi jaynewayne,

    As mentioned, updating you the progress of issue after the chat. I'm afraid, the backup just got terminated with the following error:

    Unfortunately, the debug.log file doesn't help much about what's causing the issue. Could I know whether you are comfortable if I temporarily disable the ALL in One Migration plugin, and run one more test backup to see how it goes?

    Please do let us know so that we could help get this sorted asap. Have a good day.

    Regards,
    Nithin

  • jaynewayne
    • New Recruit

    Hi, I just tried to create a managed backup while the all in one plugin is disabled. It backed up successfully and I would like to know what you added to the wp-config.php file for it to work. So that I can tell our developers what to do. Thank you and have a great day.

  • Nithin
    • Support Wizard

    Hi jaynewayne,

    Sorry for the delay in getting back to you. We reply to tickets based on queue orders, so all the member's issues are looked upon equally.

    Regarding the issue, glad to hear the changes done have worked with All in One Migration Plugin disabled. What I have done was add the following rules inside wp-config.php file:

    define('SNAPSHOT_MB_BREADTH_FIRST', true);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define( 'SNAPSHOT_BACKTRACE_ALL', true );

    It was added just before the line /* That's all, stop editing! Happy blogging. */ in the wp-config.php file.

    Then increased the memory of the website, by editing the php.ini file added in the root directory, and adding the following line:
    memory_limit = 512M

    The root directory is where the wp-config.php file resides.

    Then, in the Snapshot plugin settings, under Snapshot > Settings > Global File Exclusions, I have excluded the following files, and folders:
    ai1wm-backups, debug.log, wflogs, cache, wordpress-4.9.8.zip

    Where ai1wm-backups folder was backups created by All in One Migration plugin which was quite large. debug.log was excluded due to debug mode enabled, and wflogs, and the cache isn't required as backup as they are created dynamically.

    I hope this helps with other websites too. Have a good day ahead. :slight_smile:

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.