[Snapshot] managed backups gives error

Hi. I am experiencing a backup issue when I try to run a managed backup within my site - I am getting the error "Other kind of backup error".

Snasphot log is saving:

Warning] API connection to current-local-status returned non-200: 400
Error] Error processing manual backup: unknown:unknown
Notice] Other kind of backup error

  • Nithin
    • Support Wizard

    HI RaBaLuPe,

    Hope you are doing good today. :slight_smile:

    I checked your server and could notice a /images folder in the root directory which is really big. Is that folder required as it doesn't seem to be part of your WordPress installation? I have temporarily excluded that folder from backup, under Snapshot > Settings > Global File Exclusions

    On further troubleshooting for server resources, I created an info.php file and accessed via the browser by going to the URL:
    yourWebsiteURL.com/info.php

    On checking the memory_limit, and the max_execution_time was set to low, ie memory at 256M, and max_execution_time at 160.

    I could notice that memory limits, and max_execution time was increased via php.ini and wp-config.php file. But, the server isn't picking or reading these values, and it's still picking memory_limti as 256M, and max_execution as 160.

    It seems like you server doesn't support increasing the memory limits via php.ini, nor wp-config.php file. Could you please bring this into your hosting provider's attention, and ask them to increase the memory limit, and max_execution_time to the following?

    upload_max_filesize = 256M
    post_max_size = 512M
    memory_limit = 1024M
    file_uploads = On
    max_execution_time = 300

    Once done, please run a backup, and see how that goes. Looking forward to your response on the status regarding this. Have a good today. :slight_smile:

    Regards,
    Nithin

  • RaBaLuPe
    • Flash Drive

    Hi again. Thanks for the time and support.

    1. The /images folder is important since it contains all the images for the newsletter.
    1.a Can I smush that directory to make it smaller? ( I tried to directory smush, but I could not choose that dir).
    2. I did change the php-settings in the htaccess file, with the . And that seems to fixed the snapshot issue. All the mentioned settings are shown as active.

  • Nithin
    • Support Wizard

    Hi RaBaLuPe,

    Hope you are doing good today. :slight_smile:

    1. The /images folder is important since it contains all the images for the newsletter.

    Could I know which exact plugin is using those /images folder? It isn't a recommended workflow for plugins to add directories in the root folder.

    1.a Can I smush that directory to make it smaller? ( I tried to directory smush, but I could not choose that dir).

    I'm afraid, Smush Directory Smush will only help with optimizing images inside the /wp-content folder, as that would be where media files would be present or added by plugins in general.

    /images folder do look really large, what's the size of the folder? Maybe you could manually zip the /images folder rather than including the folder in Snapshot? It'll require a lot of server resources if the /images folder is included in the backup.

    2. I did change the php-settings in the htaccess file, with the . And that seems to fixed the snapshot issue. All the mentioned settings are shown as active.

    Sorry, could you please explain what exact changes were done? I could notice the memory limit has been increased. However, the max_execution_time is still 160.

    Please do try increasing the value of max_exeuction_time too? That's to 300, or greater value as mentioned in my initial reply.

    Please do let us know if you have further query. Have a good day. :slight_smile:

    Regards,
    Nithin

  • RaBaLuPe
    • Flash Drive

    Hi again.

    The /images are used in most of the 950 blog intries. They are imported from an old site. Is that a bad idea?

    I tried to copy the folder to wp-content and smush it.. Did not complete.

    And you're right about the php settings and the php time limit. They are 160 again. But the settings saved must have been reversed, since I had the correct settings when I replied.

  • Nithin
    • Support Wizard

    Hi RaBaLuPe,

    The /images are used in most of the 950 blog intries. They are imported from an old site. Is that a bad idea?

    Sorry for the delay in getting back to you. It entirely depends upon the size of the folder, and the server resources on which the plugin could backup this folder.

    I checked the max_excecution_time, and it seems to be at 300 now, which seems fine. Also, please do update Snapshot to latest version 3.2.1, which has many improvements.

    Doesnt matter anymore. I manually "smushed" all the files with Irfanview. Took 2 minutes instead of a day.

    I suppose you found a way to compress the images, what would be the total size of the folder? Does compressing the images makes any improvement?

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.