Snapshot Managed Backups not working

I need help. I do not have the "Destinations" menu item in the administration panel and it turns out I can not backup to your repository. (I can only do local backup on my server). What steps should I take to correct the situation?

  • Huberson

    Hey there Pavel,
    Sorry for the late response. Try increasing WordPress memory limit from the site configuration file.
    define('WP_MEMORY_LIMIT', '256M')
    Basically, add the above line in wp-config.php, re-install Snapshot then paste in your key for Managed Backup.

    Also set debug flags to true in wp-config.php

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );

    In case the first option doesn't solve the issue, please upload the "debug.log " file here. Should be located under your /wp-content directory.

    Bestt,
    Huberson

  • Pavel

    Hello! Now the page Dashboard displays this error.
    It began to display an error as soon as I did everything according to your instructions (see above).

    Fatal error: Uncaught Error: Call to undefined function curl_init() in /var/www/bank390.ru/html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/aws/AWSSDKforPHP/lib/requestcore/requestcore.class.php:615 Stack trace: #0 /var/www/bank390.ru/html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/aws/AWSSDKforPHP/lib/requestcore/requestcore.class.php(837): RequestCore->prep_request() #1 /var/www/bank390.ru/html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/aws/AWSSDKforPHP/services/s3.class.php(923): RequestCore->send_request() #2 /var/www/bank390.ru/html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/aws/AWSSDKforPHP/services/s3.class.php(1672): AmazonS3->authenticate('wpmudev.snapsho...', Array) #3 /var/www/bank390.ru/html/wp-content/plugins/snapshot/lib/Snapshot/Model/Full/Remote/Storage.php(790): AmazonS3->list_objects('wpmudev.snapsho...', Array) #4 /var/www/bank390.ru/html/wp-content/plugins/snapshot/lib/Snapshot/Model/Full/Remote/Storage.php(854): Snapshot_Model_Full_Remote_ in /var/www/bank390.ru/html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/aws/AWSSDKforPHP/lib/requestcore/requestcore.class.php on line 615

    As soon as I turn on the plugin, it immediately gives an error.

    What to do next?

  • Huberson

    From this error, looks like PHP curl module is not installed or disabled from your server.
    If you have ssh access to the server, you can check that with php -m command or look under under php > apache > conf.d directory if you have Apache with PHP configured as module.

    In case it's not installed, you can use apt(Ubuntu server) or yum(CentOS) to install it
    yum install php-curl
    or
    apt-get install php-curl

    If that take care of the error, you can retry with Snapshot again to test the result.