Snapshot Managed Error

Im getting this when trying to run a managed backup:

Aw shucks, something went wrong :( Instead of the beautiful response we expected, we got this:

<empty response>

This is a new error with the latest version.

  • Nastia

    Hello Mike D , I trust you are doing well!

    Would you please try to increase the max execution time on your site? Right now is set to 3 seconds, the Managed backups require at minimum 150 seconds.

    Please add the following to your .htaccess file:

    php_value max_execution_time 180

    And check if the max execution time value has changed from the WPMU DEV > Support > Support Info

    If not, please try other solutions that are described in this blog post, like creating the php.ini file inside the wp-admin folder with the code bellow:
    max_execution_time = 180

    This should fix the <empty response> message when you are running manual backups.

    As for these errors:

    [Warning] API connection to get-token returned non-200: 401
    [Warning] Unable to get fresh token

    It looks like the connection is not authorized, maybe the API Key is incorrect. Would you please reset the WPMU DEV API Key, and after generate a new Snapshot key and try again?

    You can reset the WPMU DEV API Key from the HUB:
    https://premium.wpmudev.org/hub/account/

    After this, you will need to login to your dashboard again.

    Let me know how it went!

    Kind regards,
    Nastia

  • Sajid

    Hello Mike D,
    Hope you are doing good today :slight_smile:

    Thanks for keeping the support staff access open. I could replicate this issue on your website. I can see that, the second AJAX request is failing with 500 internal server error (see screenshot).

    The most common reason for this error is limited memory limit and execution time. That's why Nastia suggested you to increase the execution time at first.

    If you say, its been working before, then do you remember installing/updating any plugin or theme ? If yes then please disable that plugin and then check again.

    Also, in case you don't remember than making a plugin/theme conflict would be helpful to find the culprit. Please see the flowchart on our getting support manual to make a plugin conflict test.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid

  • Mike D

    The problem with a plugin theme test is that I don't have a backup while I try those steps incase something gets messed up by activating/deactivating plugins. Also, the link you gave me doesn't work. Anyways, its time to move on. I have been held up by this plugin for far too long, so many different obstacles have come up. Unless you guys know what the exact problem is, I don't want to troubleshoot anymore.

  • Nastia

    Hello Mike D , I trust all is well!

    As Sajid mentioned, the most common reason of the 500 error is limited execution time. I visited your site and it still set to 30 seconds. If you wish I can change it on your site, but to do this I need your credentials. Would you please send it to us?

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select “?*I have a different question*?" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Nastia"
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference https://premium.wpmudev.org/forums/topic/snapshot-managed-error
    - any other relevant urls

    Thank you,

    Kind regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.