Snapshot no super admin after restore

Hi,

I have just restored from a snapshot and now have no super admin access.

It appears I have been re registered as just admin.

Please could you advise how to fix.

Thanks

  • Timothy
    • Chief Pigeon

    Hey Nick.

    1. login to your database with phpmyadmin if you have it.
    2. Find your admin user, get the user_id for it - probably 1.
    3. Go to the wp_usermeta table and look for the options wp_capabilities and wp_user_level
    4. Set the wp_user_level line to 0.
    5. Set the wp_capabilities line to
    a:1:{s:13:"administrator";s:1:"1";}

    Let me know how that goes. :slight_smile:

    Take care.

  • harryhayes
    • The Incredible Code Injector

    Hi Tim

    Thanks for the help.

    It does not seem to have worked however.

    I had to change the 4. Set the wp_user_level line to 0. as this was set to 10.

    I am still shown as an administrator role only. (in the users menu).

    I was not sure if this was suppose to be the case as I seem to have extensive capabilities, however, I am unable to make Forum entries in the back end whereas I was sure I was able to before the restore.

    ?????? :slight_frown:

  • Paul
    • The Green Incsub

    harryhayes, I'm looking into they issues. I'm not sure on your comment "Set the wp_user_level line to 0" On my local MU site the default user's wp_user_level is 10. And the wp_capabilities is the same as Tim's reply.

    One other note the prefix wp_ must match your database.

    Here is a screenshot of my own usermeta for the default superadmin user.
    http://screencast.com/t/1AUglai6dX

    I will try the restore when I get a chance.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.