Snapshot not actually restoring

Hi - I have imported a snapshot of our site to this dev site. However the restore process does is not working. When I select restore and use the default selections to restore all data from the archive, I get a restore success message - but nothing has actually happened. When I select restore and select restore select files, and then leave all of them checked - I get a hung screen. The plugin looks to have determined all the files to be restored, but then has no progress on the files and no abort option, either.

  • Sajid

    Hi @Kidpower,

    Hope you are doing good today :slight_smile:

    Its appears to be issue with max memory limit and max execution time. Please increase the memory limit following the steps mentioned in this article and then try again.

    We have also wrote a detailed article on how to migrate site with snapshot that will help you make it work as well.
    https://premium.wpmudev.org/blog/easy-migration-snapshot/

    Hope that helps! If you still need assistance, please don't hesitate to ask.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Kidpower

    Hi Sajid J,

    Thank you for these helpful links. I had not found these in my searches for articles and support prior. I am in progress on applying these changes one by one and testing them to see if that clears things up.

    So far, no luck on changing values in php5.ini, though I wonder if I need to significantly increase the limits suggested.

    The .zip of our other site's Snapshot is 1.5G.

    The other anomaly I've found in the restore process is that the instructions for migration state that Wordpress Global Files should be selected. However, this snapshot does not appear to have any... maybe this will clear up after I ammend the .htaccess file, or increase the php5.ini size limits?

    Will update after further testing - just wanted to get these two points up in case it points to another solution.

    Cheers,
    Beth at Kidpower

  • Kidpower

    I have increased the size limits in php5.ini to 3000M, 4000M & 5000M, respectively... time max to 240.
    I have added the following to the wpconfig file:
    define('WP_MEMORY_LIMIT', '3000M');

    My attempts to add the required code to .htaccess all resulted in server errors -- so that is not reset.

    Still no actual progress *and no errors* on loading the files from the imported snapshot to this dev site.

    Any more tricks to try?

    Thank you!
    Beth at Kidpower

  • Nastia

    Hello @Kidpower, I hope you are well today!

    I logged in to your site using support staff access and found the following javascript error message is displayed in the browser console:
    Uncaught TypeError: Cannot read property 'length' of undefined

    And it's coming from snapshot-admin.js

    Would you please enable debugging mode? Please put the following code into wp-config.php file:
    define( 'WP_DEBUG', true );

    Let us know when you do!

    Kind Regards,
    Nastia

  • Kidpower

    Hi Nastia,

    Thank you for checking out the site and attempting to run the snapshot. I have added the debug code into the config file.

    I also noticed a new error log - with only one entry for the membership plugin this morning:
    [02-Jan-2016 22:44:41 UTC] PHP Fatal error: Call to a member function membership_perform_cron_processes_quarterhourly() on a non-object in /home2/kidpower/public_html/dev-kidpower/redesign/wp-content/plugins/membership/app_old/membershipincludes/classes/membershipcron.php on line 138

    I have no idea if this might be related, but know you wouldn't see it via the browser.

    Thank you for the assistance!

    Beth at Kidpower

  • Nastia

    Hello Beth!

    I hope you are doing well today!

    I have tested the Snapshot on my end, and it's working.

    I would like to investigate this further. Would you please send me your credentials from your main site and developing site, so I could run a snapshot back up, and after to restore it on your developing site?

    You can send credentials by using our secure contact form https://premium.wpmudev.org/contact/

    Subject: “Attn: Anastasia”
    Main Site
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)

    Developing site
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)

    -link back to this thread for reference
    -any other relevant urls

    Visit our contact page:
    https://premium.wpmudev.org/contact/
    Select “I have a different question” for your topic - this and the subject line ensure that it gets assigned to me.

    Will be awaiting for your email!

    Kind Regards,
    Nastia

  • Nastia

    Hello @Kidpower, I hope you are doing well today!

    Thank you for sending your credentials! Please accept my apologies for my delay in responding. The Snapshot files are too big and they needed to much time to create and transfer from one folder to another.

    It seems that you do not have PclZip compression enabled on your server. I switched the Snapshot compression setting from PclZip to ZipArchive on your main page.

    The PclZip compressed files were giving me an error:

    UNABLE TO LOCATE TABLE RESTORE FILE FROM ARCHIVE: *.sql

    The ZipArchive Snapshot worked fine while I was restoring it on the development site.

    The last backup I created I did not include Media files because it was taking too much time. You will have to create a new backup with all media files include and restore in again on the development site. Please in you haven't enabled PclZip compression, leave the settings as ZipArchive.
    Or you can transfer them manually to your development site, you can copy and move wp-uploads file via cPanel or FTP

    If we may be of any further assistance, please, let us know!

    Kind Regards,
    Nastia

  • Kidpower

    Hi @Nastia -

    Thank you for working on this!

    I'm concerned that the size of the backup is possibly the real issue? I see that plugins and themes were loaded on our dev site from your migration - but no posts, pages or media library.

    Since I had used ZipArchive originally - not PcLZip - could you send me the details of all the other settings you selected with the back-up on the main site and the restore on the dev site? Maybe I've been selecting some other settings that are getting in the way?

    Thank you!

  • Nastia

    Hello Beth, I hope you are well today!

    I had followed the directions from the following blog post:
    https://premium.wpmudev.org/blog/easy-migration-snapshot/

    With a difference that I didn't include .htaccess and wp-config.php files from What Files to Archive -> Include selected files

    I'm concerned that the size of the backup is possibly the real issue?

    The back up size may be the issue, but if you increase maximum upload and PHP memory limit you should not get an error related to this.

    Please see the article below, about how to increase PHP memory limit and maximum upload:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    You may choose to run a separate back up for you Media files only, and the last option is to move the media Files from wp-content/uploads manually using FTP.

    In Snapshots -> Settings -> Compression Library, choose ZipArchive for compression option.

    Since I had used ZipArchive originally - not PcLZip

    When I visited your web site, PcLZip compression was selected in Snapshot -> Settings.

    I hope this helps! Let me know if you still have troubles with Snapshot!

    Kind Regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.