Snapshot not adding destinations

Snapshot has stopped backing up my multisite and will not allow me to add any external destinations. Clicking on 'Get Authorization Code' just reloads the Destination info page.

  • Ash

    Hello zapprabbit

    Which destination you are trying to add? Drive or dropbox or amazon?

    Also, it seems there is an error the backend. Would you please enable debug mode and check if there is any error? To enable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', false );

    to

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Now, try to add a destination again. That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

    Have a nice day!

    Cheers,
    Ash

  • zapprabbit

    20-Mar-2019 02:27:00 UTC] PHP Notice: Undefined index: destinations in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-dropbox.php on line 3
    [20-Mar-2019 02:27:00 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-dropbox.php on line 3
    [20-Mar-2019 02:27:00 UTC] PHP Notice: Undefined variable: item in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-dropbox.php on line 42
    [20-Mar-2019 02:27:00 UTC] PHP Notice: Undefined index: destinations in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-google.php on line 3
    [20-Mar-2019 02:27:00 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-google.php on line 3
    [20-Mar-2019 02:27:00 UTC] PHP Notice: Undefined variable: item in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-google.php on line 42
    [20-Mar-2019 02:27:00 UTC] PHP Notice: Undefined index: destinations in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-amazon.php on line 3
    [20-Mar-2019 02:27:00 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-amazon.php on line 3
    [20-Mar-2019 02:27:00 UTC] PHP Notice: Undefined variable: item in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-amazon.php on line 42
    [20-Mar-2019 02:27:00 UTC] PHP Notice: Undefined index: destinations in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-sftp.php on line 3
    [20-Mar-2019 02:27:00 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-sftp.php on line 3
    [20-Mar-2019 02:27:00 UTC] PHP Notice: Undefined variable: item in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-sftp.php on line 42
    [20-Mar-2019 02:27:00 UTC] PHP Notice: Undefined index: destinations in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-local.php on line 3
    [20-Mar-2019 02:27:00 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-local.php on line 3
    [20-Mar-2019 02:27:00 UTC] PHP Notice: Undefined variable: item in /home/mbaben/public_html/wp-content/plugins/snapshot/views/boxes/destinations/widget-local.php on line 32
    [20-Mar-2019 02:27:00 UTC] PHP Strict Standards: Declaration of iconNavs_Edit_Nav_Menu_Walker::start_el() should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in /home/mbaben/public_html/wp-content/plugins/iconic-navigation/iconavs_menu_fun.php on line 349
    [20-Mar-2019 02:27:00 UTC] PHP Notice: Undefined offset: 0 in /home/mbaben/public_html/wp-content/plugins/frontend_builder/functions/shortcode_list.php on line 2202
    [20-Mar-2019 02:27:01 UTC] No active Easy FancyBox media types set.

  • Nithin

    Hi zapprabbit,

    Sorry for the delay in getting back to you. Thanks for sharing the debug logs, unfortunately, the logs don't give much clue regarding what exactly is causing this.

    Just to be sure, you notice the issue with add all destinations? or is it only specific to anyone? Seems like support access to your website wasn't enabled, so I couldn't look further in the dashboard side.

    Could you please send us your websites credentials, so that we could give a closer look.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login URL
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi zapprabbit,

    Sorry for the delay in getting back to you. Thanks for sending the login credentials, I gave a closer look regarding this in your website and could notice the issue, I'm afraid the issue is more related to a conflict in your system.

    The website seems more like a live site. Is it possible to set up a staging website, where you could try running a conflict test which should help in determining where the conflict is located?

    In general the Destinations page, under Snapshot > Destinations, should list out Google Drive, Amazon S3 along with Dropbox in your system, I only see Dropbox listed.

    This is how it's supposed to look:

    I could notice the WordPress version running is 4.7.13, and the latest version is 5.1.1. I tried to set up a similar install and tried testing in version 4.7.13 to see whether I could replicate the issue, but it seems to work fine.

    Also, checked whether the debug logs, and console errors could give any clue, but I'm afraid, it's more of conflict with the existing plugin, or theme. Could you please check whether you could run a conflict test in your system as mentioned in the flowchart?
    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    If not, I'm afraid setting up a staging(clone) website of your live site and running conflict test would help in understanding where the issue is.

    You can try plugins like Shipper Pro to migrate to staging or ask your hosting provider to set up a staging site on your behalf so the issue could be looked into further.

    Looking forward to your response on how you are looking forward to troubleshooting this. Have a nice day ahead. :slight_smile:

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.