Snapshot Not Finishing Backup

Hello,

I am having some trouble with Snapshot and unable to complete a backup. The problem appears to be within Themes and/or Plugins, as individual backups of just those fail when the backup get to the files. I have tried a managed backup as well, but also receive a 404 error. Please advise.

  • Mtwo

    Hello, and thanks for the reply. I added the provided to wp_config and I was able to Snapshots of Themes and Plugins by themselves. However, a Complete Snapshot failed with 'Error 404' and stopped on Files: : media/2016/11 @ 77% (files 10/13). The related log entry within debug.log is:

    PHP Notice: Indirect modification of overloaded element of WP_Hook has no effect in /home/user/public_html/dev.domain.com/wp-content/plugins/snapshot/lib/WPMUDEV/Dashboard/wpmudev-dash-notification.php on line 58

    I did not see any other error logs or similar that would help with this issue. I also attempted a Managed Backup and it failed with a 404 about 1 minute in. While a backup was running, I tried to load the Dashboard in another tab with and Error 500. Any other ideas?

    Thanks

  • Mtwo

    Hello, I hope you are doing well. Snapshot is still having trouble and below is from the end of the Managed Backups Log:

    [Cron][2017-01-12 09:27:13][Info] Next process kickstart action scheduled for Thu, 12 Jan 2017 09:32:13 +0000
    [Cron][2017-01-12 09:27:13][Info] Processing backup
    [Queue][2017-01-12 09:27:13][Notice] Fetching [250] files as chunk 34
    [Cron][2017-01-12 11:39:17][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-01-12 11:39:17][Info] Processing backup
    [Queue][2017-01-12 11:39:21][Notice] Fetching [250] files as chunk 35
    [Cron][2017-01-12 13:35:15][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-01-12 13:35:15][Info] Processing backup
    [Queue][2017-01-12 13:35:19][Notice] Fetching [250] files as chunk 36
    [Cron][2017-01-12 15:00:39][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-01-12 15:00:39][Info] Processing backup
    [snapshot][2017-01-12 15:00:40][Info] We have an offending error: unknown:unknown
    [Cron][2017-01-12 15:33:48][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-01-12 15:33:48][Info] Processing backup
    [snapshot][2017-01-12 15:33:48][Info] We have an offending error: unknown:unknown
    [Cron][2017-01-12 15:35:40][Error] Error processing automatic backup: unknown:unknown
    [Cron][2017-01-12 15:35:40][Notice] Other kind of backup error

    Individual Snapshots for Themes, Plugins, and the DB have completed successfully. A snapshot of only Media fails and a managed backup has yet to complete. I am not sure what the issue is, but was able to complete all Snapshots on the main www site yesterday. I have granted access to the www site as well, and FTP credentials provided can also access the www directory in case you want to take a look. Please advise and let me know if you have any questions.

    Thank you,
    Michael

  • Vaughan

    Hi Mtwo,

    There is probably a very large file somewhere, or a file that Snapshot doesn't seem to want to copy.

    I may need to have a look at the files in your media folders.

    Can you send your details using the following contact form:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Alternatively you can email direct to contact@wpmudev.org

    Mark for attn: Vaughan
    Include a ref URL to this thread.

    Please include the following details;
    - Site login details (super-admin if on multisite)
    - FTP login details so I can take a look at the media/heme/plugin files.

    Thanks

  • Mtwo

    Hello, I hope this messages finds you well. I did submit the requested information...Also, I am now having problems with backups on the main site. When I edit a snapshot I see the following error related to the WordPress Cron scheduler (WP_CRON).

    Your site has disabled the WordPress Cron scheduler (WP_CRON). When scheduling an archive to be created it may not run. Check your wp-config.php for the DISABLE_WP_CRON define. If found either remove it or set the value to "false".

    I have searched and tried the most frequent recommended fixed without success. Including define( 'DISABLE_WP_CRON', 'false' ); in wp_config, and I tried WP-Cron Control and added the cron job via cPanel. The scheduled snapshots are not working and only the DB snap works manually.

    I added a new Snapshot, "Complete Snapshot 2", and it failed on Files: : media 8% (files 1/13) with 404 error. What can I do to fix? Please advise.
    Thanks,
    Michael