Snapshot not loading import

Hi,

We just installed wordpress (through GoDaddy) and I'm trying to use Snapshot to import a website built locally on my machine.

When I click to restore the Snapshot, it shows the "Snapshot determining tables/files to restore" at 0% and never moves. Eventually an iframe loads with a 404 page.

Please help resolve this issue.

Thanks!

Todd

  • Nastia
    • Support Rock Star

    Hello Todd, I hope you are doing well today!

    I am sorry to hear you have this issue.

    Would you please clarify what method are you using? Is it Manged backups or you've created a snapshot from Snapshot > Add new?

    If you created a Snapshot from Snapshot > Add new please let me know how you imported the URL link, is the backup file uploaded locally or is it on a remote destination like Google Drive or Drop Box etc.

    Would you please upload the snapshot file manually using FTP and let me know if this will migrate your site?

    Also, please check the backup file and make sure that it is not empty.

    Would you please grant access from WPMU DEV > Support so I can have a closer look?

    Please see the detailed instructions on the link below:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let me know when you do!

    Kind regards,
    Nastia

  • Sajid
    • DEV MAN’s Sidekick

    Hello Todd,
    Hope you are doing good and thanks for keeping the support staff access open :slight_smile:

    I could login and noticed that upload_max_filesize and post_max_size settings values are too low. That is why server is unable to handle the process and generates 404 error in result.

    Please increase the limits for upload_max_filesize, post_max_size and max_execution_time by one of methods mentioned in this blog post and then check again.

    You should note the existing values first from Dashboard -> WPMU DEV -> Support -> System Info -> PHP to make sure your changes take effect.

    Try to increase as much as your host allows, because for larger backup files, you need more memory and execution time.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid

  • Todd
    • Design Lord, Child of Thor

    Ok I was able to get it updated, I increased it to these numbers but still having the same issue. Can you give me an idea of what these numbers should be to get it working?

    memory_limit 1024M
    upload_max_filesize 128M
    post_max_size 128M

  • Nastia
    • Support Rock Star

    Hello Todd

    I've tested your site and the backup has stayed at 0% for a vry long time. I would like to have a closer look at test the backup on my site too. Would you please send to us your credentials?

    You can send credentials by using our secure contact form http://premium.wpmudev.org/contact/

    Subject: “Attn: Nastia”
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant URLs


    Select “I have a different question” for your topic - this and the subject line to ensure that it gets assigned to me.

    Kind regards,
    Nastia

  • Dimitris
    • Support Star

    Hey there Todd,

    hope you're having a beautiful day! :slight_smile:

    I just downloaded your snapshot file after you kindly shared your FTP credentials with us and I was able to replicate this timeout issue despite the high numbers of my PHP settings.

    I also tried to restore an even larger snapshot file (~150MB) in the same test installation and I had no issues with that. This may have to do with your snapshot file, could you please try to create a new one and retest? You may also try to exclude some information (like plugins or media files) to test if there's any difference upon importing.

    Could you also please confirm that you have the "max_execution_time" set at least at "300" seconds? The admin account you created and shared with us has no access to WPMUDEV dashboard to check by myself. If you could re-grant us support access it would be perfect!
    https://premium.wpmudev.org/blog/increase-memory-limit/
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Warm regards,
    Dimitris

    • Todd
      • Design Lord, Child of Thor

      Thanks, Dimitris!

      I just reset the access through WPMU support so you should be good now to get in there.

      The time is set for 300, so that shouldn't be the issue.

      We also did run another snapshot to test after the initial and that didn't work either.

      Thanks for helping to get this issue resolved.

  • Nastia
    • Support Rock Star

    Hello Todd ,

    My apologies for the delay, I was away for a few days.

    I've downloaded the snapshot file, everything went smooth and the file was successfully restored on my localhost site.

    I've temporarily deactivated all the plugins on your site trying to restore a site and still getting 404 error. I also tried with a smaller size file and still was getting 404 error. Unfortunately, the debug.log didn't show any result.

    Would you please check the server error logs for any errors related to Snapshot? Also would you please contact your hosting provider and ask if there's anything that is blocking AJAX requests from your site?

    Please advise,

    Kind regards,
    Nastia

    • Todd
      • Design Lord, Child of Thor

      Thanks, Nastia!

      How do I check the server error logs (or get you access to do so)?

      I spoke with the hosting provider and they looked at all the settings there, and everything is setup properly same goes with the system requirements of your plugin.

  • Predrag Dubajic
    • Support

    Hi Todd,

    I was doing some additional testing with restoring your snapshot on my installations and I was able to replicate the issue with Nginx but on Apache it worked fine, however you're also running Apache so this doesn't seem to be the culprit here.

    It still seems that this is something related to server configuration but I must say that I'm getting out of ideas here.

    I have forwarded this issue to our developers so they can debug it further and see what are we dealing with here.

    Best regards,
    Predrag

  • Dimitris
    • Support Star

    Hello Todd,

    hope you're having a beautiful day! :slight_smile:

    It seems that some plugin or your active theme was messing with that... have you tried to narrow this down even more?

    You can try to delete all themes and plugins that you aren't using (as these are being included in snapshot backups) and try once more?

    Warm regards,
    Dimitris

    PS. As my colleague Predrag already informed our dev team, we'll keep you posted on any insights we get from them, as soon as possible.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.