Snapshot not restore the backup

Hi, I'm tryin to restore the backups of many site, but when I try to restore the backup it return me this error message: "An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings."

Why I have this issue? Until 15 days ago, all work fine....

  • Adam Czajczyk

    Hello GiaNet Media,

    I hope you're well today and thank you for your question!

    There's no single, specific reason for that issue, it might be caused by various "underlying problems". I would like to investigate it so could you please:

    - open support access to one of the site's affected (you can do it by going to "WPMU DEV -> Support" page in your site's back-end and clicking on "Grant Support Access" button there)
    - let me know whether you're restoring from Managed Backup or "Snapshot -> Snapshots" (if "snapshots" - which snapshot is that?)

    I also assume that you're restoring to the same site where you have taken backup, right? Or are you migrating to either different server or both different server and domain?

    Before you respond here, please also do one more thing:

    - enable WP debugging by adding following lines to the "wp-config.php" file (via FTP or cPanel "File Manager" tool) of your site, right above the "/* That's all, stop editing! */" line

    define('WP_DEBUG', true);
    define('WP_DEBUG_DISPLAY', false);
    define('WP_DEBUG_LOG', true);

    - try to restore the site again
    - look into the "/wp-content" folder of your install and if there's a file named "debug.log", download it, rename to "debug.txt".

    Please attach the file to your response here along with answers to my other questions and I'll investigate the issue.

    Kind regards,

  • GiaNet Media

    Hi, thanks for the reply.
    For now I'm tryin to migrate the backup of two live sites in localhost.
    15 days ago I have do the same process and it don't had issues.

    Now I have activated the debug, but after the Snapshot error message the system don't generate the "debug.log" file...

    If I go into the wp-content/uploads/snapshot/_restore folder I can see the databse table in sql files, and the folders with the plugins and the themes.

  • Predrag Dubajic

    Hi GiaNet Media,

    Are you using regular Snapshots or Managed Backups?

    You should note that Snapshot is not a migration plugin and even though we had number of cases it worked this way it's not something plugin was designed to do so we can't guarantee that this will work each time as it depends on large amount of parameters.

    We would still like to have a look at your backup files so we can see if there's anything wrong with them or there's something else causing this.
    Could you grant us access to one or both live sites where you created backup files so we can download them and check them on our end?

    Best regards,

  • Predrag Dubajic

    Hi GiaNet Media,

    Please don't leave your download link here as the forums are public and backups can contain sensitive data from your site, I have removed it now but in future use Message textbox in WPMU DEV > Support panel in your admin section for this kind of stuff.

    About the issue, I tried restoring the backup on my local installation and I keep getting the same error, even with just one database selected, but there are no errors in the log or anything that would give me more info about what's going on :slight_frown:

    Could you grant us support access to your source site so we can try creating couple of different backups, with different stuff included, and see how that behaves during the restore process?

    Best regards,

  • Adam Czajczyk

    Hi @gianetmedia!

    I have accessed your site and also tried to test that existing backup "InOnda Network BK...". I found out that I cannot even extract the downloaded zip file to my local drive due to some system error. I'm not sure, maybe it's just me, but in that case I have created three other backups to test it.

    You'll find them on your site as "WPMU TEST 1", "WPMU TEST 2" and "WPMU TEST 3". The "WPMU TEST 1" backup is exactly the same as yours but you'll see that it's slightly bigger. When I downloaded this file, I was able to extract it. I was also able to extract the WPMU TEST 2 which is the same but doesn't include "mu-plugins" and "WPMU TEST 3" which does include mu-plugins but no regular plugins.

    The 1 and 2 tests gave me some warnings about too long file paths, while the 3rd didn't. Since the server is not based on windows (I'm using Win 10 Pro 64b here) it might not be an issue but I'm wondering whether the first ("InOnda") backup file might be corrupted.

    While creating those backups, I noticed that during the process they seem to be "getting stuck" at 100%. It looks like they're finished and the UI hangs up. But if you use "Show full log" option then, you'd see that there are still some tasks being performed so you'd need to let them finish. This might be related in that sense that e.g. backup process might have been closed at 100% while it wasn't actually really finished, is that probable in your opinion?

    Getting back to my test files: could you try to restore (to some staging environment) from those WPMU TEST backups, please (starting from 1) to see if they work?

    Let me know please.

    Kind regards,

  • Adam Czajczyk

    Hello @gianetmedia!

    Thank you for your response. I did some more tests, setting up a separate, fresh site on my end, and I must admit that I wasn't able restore it as well even though the files doesn't seem wrong (when extracted). There's also nothing specifically unusual on your end during the backup process.

    I admit I'm a bit out of ideas so I'll need to include our developers in this. I'll need to ask them to check your site and see what might be causing that. However, to be able to do this, I would need a direct and full access to the site so please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) - cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here

    Kind regards,

  • GiaNet Media

    Hi, I have tried to restore in localhost two different subsite. The first is the main site of a WP Multisite installation that have the Toolset plugins installed in a subsite in the network; the second is a subsite but with his own wp installation and it is structured with the Toolset plugins.
    I have tried to do a backup and restore it in localhost with all folder and all database fields, and also only with the database fields.
    The results is the same, the both backups return me the same error message when I try to restore them, with all backup settings...