Snapshot not sending to Google Drive

Snapshot is not sending the backups to Google Drive, showing the following error:

Error: Could not send file <pre>Google_0814_Service_Exception: Error calling PUT https://www.googleapis.com/upload/drive/v2/files?uploadType=resumable&upload_id=AEnB2Up3Q75ejaR94np_go2MgLwG5RHKMZFOwYIOL0w5S2-OJAKRSJ1DMrtWyU1ebDxOAg-SoPQa4MQVMhZGCWvPSNa8IsaZAg: (404) File not found: 1PBfJ9tRu4k8T3J9Ta0Qsygl9wyP2k0Ac in /home/u41870/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/REST.php:79 Stack trace: #0 /home/u41870/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php(185): Google_0814_Http_REST::decodeHttpResponse(Object(Google_0814_Http_Request))

  • Luís

    Hi Jussi ,

    Hope you're doing well today!

    I created another Google Drive destination in your site to test this with my google account (in order to better test this an follow and the steps of the procedure), but I was not able to replicate the issue. I made 2 Snapshots (you can check them in Snapshot -> Snapshots) and they were properly sent to my Google Drive:

    I believe something in the destination you setup is not right. I may suggest you to delete the current destination and setup a new one. Please make sure you follow all the steps, i.e Directory ID is right, the Drive API is enabled on Google console.

    I hope this information has been helpful. If I can help you in this or other related question, please let me know!

    Cheers, Luís

  • James Morris

    Hello Jussi

    We have full G Suite (Google Business) accounts we can use for testing. I've created a test on one of my dev sites and was able to successfully backup to Google Drive.

    I tried accessing your site to investigate this issue further, but unfortunately access has expired.

    In order to help you better with your issue, would you please grant me access to your site and server so I can perform some advanced debugging?

    Please visit the Contact page and complete the form with the following information:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Option: I have a different Question

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    ~OR~

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • James Morris

    Hello Jussi

    Thank you for getting those details to me.

    I did notice that your memory_limit and max_execution_time in your PHP config was rather restrictive. I've updated these to improve performance of your site and Snapshots.

    Then, I created a second Google Drive destination and set it up using the credentials for our company G Suite (Google Business) account. I followed the instructions outlined in the Snapshot interface.

    I then created a test Snapshot and pushed it up to our company drive.

    Everything ran successfully without issues.

    To test whether the memory_limit and max_execution_time had an affect on your drive destination, I regenerated your backup and tried to push it up to your drive. It failed again. This indicates that your credentials are setup incorrectly in Snapshot.

    Can you please remove the destination and set it up from scratch, being very careful to follow the steps outlined in Snapshot? Please note that the Authorized redirect URIs are especially important.

    Best regards,

    James Morris