Snapshot not working

I've seen that many of my website don't have managed backup working, I already checked in 5 sites.

  • Ashik
    • Staff

    Hi Michel,

    Thank you for reaching WPMU DEV support. Hope you're doing well today.

    Sorry to hear Snapshot isn't working on your sites. I was able to login using given credentials and could fix the issue for 4 sites among 5. For the other one getting internal server error issue. I'll check again this one and keep you posted here once I'll have any confirm result.

    I've increased memory limit, execution time and added a few Snapshot constants in wp-config.php file to made Snapshot workable. Below is the details code :slight_smile:

    Code to increase memory limit and execution time

    //increase memory limit
    define( 'WP_MEMORY_LIMIT', '1024M' );
    //increase execution time
    set_time_limit(300);

    Snapshot constants

    // Snapshot settings - start
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600); //100MB
    define('SNAPSHOT_IGNORE_SYMLINKS',true);
    define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_BACKTRACE_ALL', true);
    define('SNAPSHOT_SYSTEM_DEBUG_OUTPUT', true);
    // Snapshot settings - end

    Feel free to reply here if you've more questions or concerns. Have a great day.

    Regards,
    Ashik

  • Ashik
    • Staff

    Hi Michel,

    Yes, you're right. Snapshot Managed Backups working for the 4 sites among 5 as I mentioned above. But sorry, I'm unable to fix the issue for jonqueresdoriola. So, I've escalated this to our second level support (SLS) team for further troubleshooting. They will take care of it from now and get back to you here with a possible solution.

    Kindly note that SLS team working on this kind of more complex issues. So, they might delay here to respond. I expecting your patience on this.

    Feel free to reply here if you've any more questions or concerns. Have a great day ahead.

    Regards,
    Ashik

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Hi Michel ,

    It seems that the server is always timing out when the backup process reaches the uploads folder. I see that you have some files in there that are ~250mb each ( videos to be more precise ).

    Is there a possibility for us to have a server/Cpanel access to see if we can raise those timeouts or check for any other errors server-side while trying to compress those files ?

    You can send me the information needed privately through our contact form at https://premium.wpmudev.org/contact/#i-have-a-different-question by following this example:

    Subject: "Attn: Konstantinos Xenos"
    
    - Server Admin ( CPanel / Plesk / Any other Server Admin panel )
    Username:
    Password:
    Login URL:
    
    - Link back to this thread for reference
    - Any other relevant URLs -or- information regarding the issue that was not included in this thread

    Regards,
    Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.