Snapshot not Working

I am trying to move a multisite and used snapshot. I finally got my server to allow the backup to fully restore, but when I restore the backup, it requires me to click on something to update the databases (I think that's what it was, I wish I had taken a screenshot). Then I am given a message "Sorry, you are not allowed to access this page." anywhere in /wp-admin.

I did this on both rocket.fish/ellen AND rocket.fish/ellen2

My steps were to install a clean WP and then install both WPMUDEV and Snapshot plugins, and then upload my snapshot zip file, restore from there.

Any help appreciated!

  • Kasia Swiderska

    Hello alisa,

    Are you able to login at all to wp-admin on restored site? The "Sorry, you are not allowed..." message is usually caused by what's called a "nonce". It's a kind of additional security layer used by WordPress, a sort of "one time/time valid" code so when this is either "broken" or expired, it would cause such issues.

    If you still got an access to the dashboard in general, please give these steps a try:

    1. If there's any caching plugin on site, clear all the caches and disable cache
    2. if there's any additional cache on server, also clear it up and deactivate if possible
    3. Go to "Plugins -> All plugins" page and deactivate all plugins
    4. Go to "Themes" page and switch to one of the standard themes such as Twenty Fifteen or Twenty Sixteen

    5. Logout of the site and clear your browser cache
    6. Login back to the site

    Then please start enabling all the plugins (except cache) one by one each time checking if you can access everything. If at some point you experience the issue again, please note down what was that moment so we know about the plugin that's interfering. If everything works fine after enabling all the necessary plugins, switch back to your theme of choice and check again.

    If everything's still fine, re-enable caches and see what happens.

    There's a good chance that these steps alone will solve the issue but if they don't please report the details back to me and I"ll further investigate that.

    if you don't have access to wp-admin disable all plugin through the FTP by going to wp-content and renaming plugin directory. Let me know if this will help.

    kind regards,
    Kasia

  • alisa

    It's still not working. :slight_frown:

    I did another snapshot just in case and another clean install of wordpress. It goes through all the steps smoothly, and then it makes me update my wordpress database, and when it completes it locks me out with "Sorry, you are not allowed to access this page." That's what comes up anywhere, including /wp-admin (I can get to /wp-admin if I log out).

    If I go to the website I can see it, and it looks like I'm logged on (it shows the bar at the top with my login), but I am unable to get to admin area.

    I did also try manually changing the plugins folder and still no luck. Nothing seems weird in the .htaccess file either.

  • alisa

    It looks like my databases are using the old domain mapping for the root domain, I assumed that because the plugins include the import of the sql files that it would change the databases as part of the restore. Did I miss a step, or? Is there a way to manually fix this? Do you think that could be the issue?

    I'm happy to send you the snapshot file and I did take screenshots, I really need to get to the bottom of this so I can get the sites moved.

  • alisa

    I was able to do that on the destination site (under alisanatal@hotmail.com), but can't on the other because the original developer had an install of it and it's not activated, but I don't want to mess things up on her server if any of her sites are using it. I can provide you login but I'm not sure how to do that privately?

    I was able to get the login to work... the first step was doing as you mentioned on using the same version of wordpress install on both websites, and unfortunately then adding a user manually in functions.php.

    But now, neither a full backup of the multisite or a single site within the multisite is restoring the correct files. The pages for the main site work (but not as a multisite setup). Or, as a snapshot of a site within, again the main website pages (for the main site, not sub) and some random stuff - it didn't include plugin settings or anything else either. :slight_frown:

    Getting super frustrated because I think it would have been easier to start doing this process manually rather than using the plugin at this point. :slight_frown:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.