Snapshot not working cannot backup

Looking to create Manged Backup, but it’s creating incomplete backups of size 7MB, the site is bigger than the backup size.

Increased max_memory_limit, server resources but the issue still exists. Please check the chat notes for more info.

  • Dimitris
    • Support Star

    Hello Dave,

    hope you’re doing good today! :slight_smile:

    I’ve made some changes/additions in wp-config.php

    define('WP_MEMORY_LIMIT', '1024M');
    define('WP_MAX_MEMORY_LIMIT', '2048M');
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_IGNORE_SYMLINKS',true);
    define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_BACKTRACE_ALL', true);
    define('SNAPSHOT_SYSTEM_DEBUG_OUTPUT', true);

    as well as in .htaccess file

    php_value upload_max_filesize 1024M
    php_value post_max_size 1024M
    php_value memory_limit 2048M
    php_value max_execution_time 3000
    php_value max_input_time 3000
    php_value default_socket_timeout 3000

    but Managed Backups still can’t complete.

    I’ve gathered all debug information and forwarded to our Second Level Support team for further investigation. Please keep in mind that their response times are much wider than ours, so your patience on this is highly appreciated! Me or another colleague of mine will keep you posted here as soon as possible.

    Warm regards,

    Dimitris

  • Dimitris
    • Support Star

    Hello Dave,

    I trust you’re doing good today! Unfortunately there’s still no feedback from our SLS team. I’ve already pinged them again on this, even though they constantly work on member’s sites/tasks from oldest to newest report. We’ll keep you posted here as soon as possible! :slight_smile:

    Warm regards,

    Dimitris

  • Leonidas
    • Developer

    Hello Dave ,

    I hope you’re having a great day :slight_smile:

    We’ve been running tests on your site regarding your reported issue and while we haven’t been able to fully complete a backup there yet, I was wondering if you could provide us with credentials to the site’s cPanel in order to closely monitor the activity on the server during the backup process? That would give us a great insight as to why the backup processes fail exactly.

    Please visit the Contact page and complete the form with the following information:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Option: I have a different Question

    Subject: “Attn: Leonidas Milosis”

    In the Message box, please provide the following:

    – link back to this thread for reference

    – any other relevant urls

    – Hosting Control Panel Login

    Admin username

    Admin password

    Login url

    Best regards,

    Leonidas

  • Dave
    • Flash Drive

    Hi Leonidas,

    Sorry for the delay of reply. We did a few tests and found out in debug.log that Snapshot is trying to access a non-existing table on several sub-sites. Here’s one of the errors (* is intended) :

    WordPress database error Access denied for user '******'@'localhost' (using password: YES) for query SELECT count(*) as total_rows FROM '*****_14_affiliate_wp_campaigns'; made by do_action('wp_ajax_snapshot-full_backup-start'), WP_Hook->do_action, WP_Hook->apply_filters, Snapshot_Controller_Full_Ajax->json_start_backup, Snapshot_Controller_Full->_start_backup, Snapshot_Model_Queue_Tableset::all, Snapshot_Model_Queue->add_source, Snapshot_Model_Queue->_update_source, Snapshot_Model_Queue_Tableset->_get_source_defaults, Snapshot_Helper_Utility::get_table_segments

    We can give you a WHM access but we will need to allow your IP address first. Can you send us your IP address.

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.