Snapshot now backing up my sites :(

Part of my decision as to whether I continue with this membership or itheme is the staging functionality. iThemes is really buggy, but when it works, it works well and easily. (probably because I've spent so many hours with support troubleshooting, I know the steps when I get stuck....)

At any rate, my issue is this. My staging site (gella.secondnaturebeauty.com/dev) and my live site franciscogelladance.com will not backup with this service. The backend just blows up and won't do anything everytime I try to create a snapshot and press the "backup now option."

Any idea what's happening?

  • Dimitris
    • Support Star

    Hey there Amara,

    hope you're doing good and thanks for reaching us! :slight_smile:

    Have you tried to create normal Snapshots, like from Snapshots -> Add new or a Managed Backup? Please advise!

    Could you please access your server through FTP, edit the wp-config.php file and insert the following line just above the /* That's all, stop editing! Happy blogging. */ comment
    define('WP_MEMORY_LIMIT', '512M');
    Ref: https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Then go ahead and try to increase the max_execution_time to a higher value like 300. Here's a nice blog post with instructions:
    https://premium.wpmudev.org/blog/increase-memory-limit/
    Just keep in mind to double check that changes has effect in WPMUDEV -> Support -> System Info [button] -> PHP [tab] -> max_execution_time.
    If it doesn't reflect there, please contact your hosting provider on how to increase this value.

    Then try to create a backup. If the issue persists, access your server via FTP again, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to replicate the error by trying to create a backup again.
    By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. If size of text file exceeds the 5MB limit of our blog, please use a service like Dropbox and post the shareable link instead.
    Ref: https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    If you're trying Managed Backups, please also enable the "info" debug level in Snapshot -> Managed Backups -> Settings [box] before trying to create your backup.

    Finally, grant us with temporary support access to your website via WPMUDEV Dashboard plugin as described here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Looking forward for your results!
    Warm regards,
    Dimitris

  • Amara
    • Flash Drive

    Hi! Yes, I have tried to create a normal snapshot, but it's just not working. :slight_frown:

    wp-config.php - done

    scared to increase the memory limit to 300 due to server limitations. It's at the max of 256. I was told that could make things unstable if I add any more.

    You've been given access to one of the sites. I don't want to mess up the live site. (not saying you would... I've just had the worst luck with the live site today... smh).

    Thanks for your help!

  • Dimitris
    • Support Star

    Hey there Amara,

    appreciate the additional info provided here!

    As long as you aren't trying with managed backups, could you please proceed with the activation of WP_DEBUG as I described in my previous reply? Then try to perform another snapshot and share the debug information.

    By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. If size of text file exceeds the 5MB limit of our blog, please use a service like Dropbox and post the shareable link instead.
    Ref: https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    Warm regards,
    Dimitris

  • Predrag Dubajic
    • Support

    Hi Amara,

    It seems there are just notices in there and those shouldn't have any effect to creating backup, I have however forwarded it to plugin dev as well to check if he sees something I'm missing.

    While I wait for his feedback can you try changing chunk size by adding this code in your wp-config.php (located in root WP folder) file just above /* That's all, stop editing! Happy blogging. */ line:
    if (!defined('SNAPSHOT_TABLESET_CHUNK_SIZE')) define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);

    Run the backup again after that and let us know if that makes any difference.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.