Snapshot of a subdomain when www is displaying

To start I selected Scribe as the items I need support on but it is not.
I need support with Snapshot but it was not listed as one of my options.
I am using the Snapshot and want to take a backup of a subdomain. The problem is that the domain displays with the 'www' prefix. So when I try to select the subdomain I want to back up and press the Lookup button there is an error.
So I guess I need to remove the "www" to make the Snapshot of a subdomain work. However, I cannot find where to change the setting. I thought the selection for www or non-www was in Settings but I could not find it.
Also I have an SSL cert on this domain which I think said it requires http://www...I dont know much of anything about SSL so please let me know if I can get away with not using www for SSL

  • Adam Czajczyk

    Hello Lnunnally,

    I hope you're well today and thank you for your question!

    You're right about the reason for the issue: the "www" prefix is interfering with the "Lookup" feature. WordPress Multisite that's set to use sub-domains shouldn't use "www" prefix as it may lead to unexpected issues such as this. This is set during setting up a Multisite install but fortunately you do not need to change it now as there's a workaround:

    1. Go to the "Network Admin -> Sites -> All sites" page
    2. Hover over the site (blog) that you'd wish to backup
    3. In a browser status bar at the bottom you'll see an URL similar to this one:

    https://www.yoursite.org/wp-admin/network/site-info.php?id=2

    Note that value of an ID (it's "2" in an above example)

    4. Get back to snapshot creation and instead of a blog name/subdomain put that value ("2" in this case, no quotation marks, just the number) into the lookup field and press "Lookup" button

    This will search for the site by its ID instead of a name/subdomain.

    I hope that helps!

    Best regards,
    Adam