Snapshot on shared hosting? 120 max execution time

Hi!

I’d like to use Snapshot on one of my clients sites, but he is on shared hosting, with php_memory_limit 128MB and max_execution_time 120. I already experimented very much with the Database Segment Size and I’m already using “ZipArchive” as Compression Library, because it’s faster. But I’m always getting the message “Internal Server Error”, and I think it’s because of the 120 seconds of max_execution_time.

Any chance to use it though? Any help is appreciated.

Best regards!

Achim

  • Kasia Swiderska

    Hello Achim,

    Can you check if you can make Snapshot only with database (no files) on this site? Only database should be much quicker and this will tell us if this is problem with memory.

    If creating small backup plugin will be fine then try to increase memory https://premium.wpmudev.org/blog/increase-memory-limit/ (if this is possible on this shared hosting)

    Let me know how it goes.

    kind regards,
    Kasia

  • Achim

    Hello Kasia!

    Only putting the database in my backup was successful. But unfortunately none of the other options works for me.

    php.ini can't be edited. adding the lines to .htaccess caused a 500-Error until i removed them again. Adding the code to the wp-config.php didn't solve the problem as well.

    I really think it's because of the low max_execution_time. Do you have any other options?
    Would it be possible to backup and restore files and database seperately?

    Best regards!
    Achim

  • Kasia Swiderska

    Hello Achim,

    I really think it's because of the low max_execution_time. Do you have any other options?
    Would it be possible to backup and restore files and database seperately?

    I recently spoke with developers about issues with big files of backups and they are working on better way of handling this (but I cannot give any ETA when this will be finished).

    You can backup files and database separately - honestly I never tested restoring that kind of backups separately.
    I think best approach will be first restoring files and then database - this is because in database there are information about active theme and plugins - and if you would do that opposite way then you could face problems about files of themes and plugins not existing where in database is information about them.
    When you restore backup manually procedure is the same - you copy files and then import database - so this should work also with snapshot.

    I really think it's because of the low max_execution_time.

    I've tested this on my site and I have exactly the same max_execution_time time but I have php_memory_limit set to 256 - so twice as you.
    I would ask hosting provider to change that for you (they sometimes agree to increase memory limits).

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.