Snapshot partially not working.

Snapshot is partially not working: Here is the issue:

Selecting run now from the all snapshot screen does not work;
Editing the snapshot and selecting run immediate does work perfectly;
Editing the snapshot and selecting manual and then selecting run now does not work;
Scheduled snapshot does not work;

I have two multisite on the same machine, using the same configuration (php-mysql-etc...) This one does not work. The other multisite work perfectly.

No log are generated.

Thanks

  • denis_grenier

    Additionnal information.

    Selecting run immediate from the edit snapshot screen does work. However, when I leave the running now screen to navigate to another page while snapshot is running, will stop the backup process.

    Error log included:

    2015-05-03 09:12:28: Backup: init
    2015-05-03 09:12:28: updating snapshot: 1429450015
    2015-05-03 09:12:28: Notice: errno:8 Undefined index: blog-id /var/www/clients/client1/web2/web/wp-content/plugins/snapshot/snapshot.php on line 6995
    2015-05-03 09:12:28: table: rt_14_commentmeta segment: 1/1
    2015-05-03 09:12:29: table: rt_14_comments segment: 1/1
    2015-05-03 09:12:30: table: rt_14_links segment: 1/1
    2015-05-03 09:12:30: table: rt_14_options segment: 1/1
    2015-05-03 09:12:31: table: rt_14_postmeta segment: 1/3
    2015-05-03 09:12:31: table: rt_14_postmeta segment: 2/3
    2015-05-03 09:12:32: table: rt_14_postmeta segment: 3/3
    2015-05-03 09:12:33: table: rt_14_posts segment: 1/1
    ~
    ~

  • Anang

    Hi Denis

    Thanks for contacting us :slight_smile: So you only get the errors only on one sub site ?Are you have same plugins installed through all sub site ? Could you give me access to your site so I can take a look over your setting and tell me what sub sites that has the problem? Here the link to give me access to your site :
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best Regards

  • Adam Czajczyk

    Hey Denis,

    I hope you're well today and thank you for your question!

    Are you using the latest Snapshot release? If not, please update the plugin.
    This behavior however is most likely caused by WP Cron not functioning properly. WP Cron is based on the site hits (visits) so the more hits the better it works. Also there's always a chance that something's blocking/breaking it. It might be for example another plugin that's interfering with Snapshot or that's using WP Cron in a non-standard, WP Codex non-compliant way.

    That said, here's what I'd do:

    1. Disable all the plugins except Snapshot and check for the issue. If Snapshot works fine, try to enable plugins one-by-one until the issue appears again. You'll find the plugin that breaks WP Cron this way.

    If it doesn't help

    2. Try switching WordPress to a real server's cron instead of WP Cron (sometimes called also a "pseudo-cron"). To do this:

    - in your wp-config.php file add this line:

    define('DISABLE_WP_CRON', true);

    - in your server's admin panel find the "Cron jobs" (or similarly named) section
    - add this command:

    wget -q -O - http://yourwebsite.com/wp-cron.php?doing_wp_cron >/dev/null 2>&1

    Let me know if it helped, please!

    Regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.