Snapshot plugin giving Error 500

I just installed Snapshot Pro for on WPMU. I've tried running it twice and both times I'm getting an error
Error 500 - Internal Server Error
An error was encountered while processing your request. Typically this is a temporary condition. Please contact the web site owner for further assistance.

It progresses almost to the bottom, but it kills over at 60% on "Files: plugins".
My MU site is really, really small as I've only been tinkering and haven't really made anything public yet.

  • Nazmul H. Rupok

    Hi there,

    Hope you are doing well today and thanks for asking! No worries, it's a common issue due to insufficient memory and should be fixed if you increase your memory limit. But first let's identify the issue. For this I need you to enable WP_DEBUG in your wp-config.php which is in the root of your WordPress install.

    1. Enable debug logging. You can do this by adding the following lines to your 'wp-config.php' file:

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    2. Increase WordPress memory limit:

    define( 'WP_MEMORY_LIMIT', '256M' );

    3. Add the following lines which are specific to Snapshot settings:

    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);

    4. Increase max execution time to 300 or more by trying the following methods.
    a. Create or edit php.ini in your website's root and add the following line:
    max_execution_time 300

    b. In .htaccess add the following line:
    php_value max_execution_time 300

    c. in cPanel you can go to "Software > MultiPHP INI Editor", choose your domain and PHP version and change the value for max_execution_time to 300 or more

    After that you can try Snapshot again. Hopefully everything should be fine. Let us know if you still face any issue.

    Have a nice day. Cheers!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.