Snapshot plugin not working

Hello,

Just purchased snapshot and when I go to Snapshot->Settings I receive the following error:

“Cannot use output buffering in output buffering display handlers in Unknown on line 0”

I’m currently running WP 3.5 and Hostgator is my hosting company.

Thank you,

Regis

  • Paul Barthmaier
    • Code Wrangler

    Hi there and welcome to the WPMU DEV Community for WordPress Support!

    This is most likely a plugin conflict. Can you disable your plugins and re-enable one by one to see which one is causing the conflict? It may be that when you enable in order of importance, you’ll find that the error goes away. Give it a shot and let us know how that goes.

    Cheers,

    Paul

  • Paul
    • The Green Incsub

    @regis_friend_cassidy, Greetings. Can you tell me how you have the HTTPS plugin configured. There was a similar thread reported some time ago and at that time the member found the issue was not reproducable on a different server.

    https://premium.wpmudev.org/forums/topic/https-snapshot-problem#post-317363

    The Snapshot plugin should not have an issue running you wp-admin under HTTPS/SSL All URLs used as relative and should properly convert to https. Give me more details and maybe we can figure this one out.

  • regis_friend_cassidy
    • WPMU DEV Initiate

    Sorry for not getting back to you all sooner! This has been low on my priority list because the only thing broken, that I can tell so far, is the settings page for Snapshot.

    Yes, the problem is still there. But I will just disable WordPress HTTPS temporarily if I ever need to tweak the settings in Snapshot.

    Thanks to all of you for your kind help.

    Best,

    Regis

  • Paul
    • The Green Incsub

    @regis_friend_cassidy,

    I appreciate that you found an acceptable solution for your own needs by deactivating the HTTP plugin and the reactivating. But I would really like to find a solution to this issue. This is probably the third reported issue I’ve seen between Snapshot and the HTTPS plugin. To be specific referring to the plugin http://mvied.com/projects/wordpress-https/

    In each reported case I’ve tested the plugin along with Snapshot under my own environments and can’t reproduce the issue. I know you are busy and this is a low priority but I’d really like to work with you to get this conflict solved and finally figured out.

    If you are not interested then I’d like to request we close this thread.

  • Kimberly
    • Champion of Loops

    Hi!

    Just checking in :slight_smile:

    I’m guessing that because we haven’t heard back from you that you’ve got your issue worked out via live chat or email, or that we have reached the end of our convo here. If you are still having problems or need any other answers on this particular topic please feel free to come back to this thread at anytime. Just be sure to mark it Not Resolved so we don’t miss it!

    This ticket is only being Resolved due to lack of activity. It is by no means an action to avoid, brush off or minimize your issue. We are ready and here if you want to re-open at any time and I apologise any lack of communication if this ticket is being closed in error.

    Thanks for being part of the WPMU DEV Community!

    Best,

    Kimberly

  • regis_friend_cassidy
    • WPMU DEV Initiate

    Well, I know Paul would like to resolve this. I just don’t know what you’d like me to do at this point.

    Please tell me what I need to do that will allow you to further troubleshoot this? But feel free to close the thread if you know longer wish to work on it.

    Thanks,

    Regis

  • Paul
    • The Green Incsub

    @regis_friend_cassidy,

    Sorry too many tickets. So on HTTPS I had another member with the same issue. https://premium.wpmudev.org/forums/topic/snapshot-with-files-not-working-on-https-site

    The solution was to increase the memory in the wp-config.php Can you try that? Note increasing the memory in the php.ini is not the same. WordPress still only sets the lower limit to 40M on single WordPress and 64M on Multisite by default.

    Reopening!

  • regis_friend_cassidy
    • WPMU DEV Initiate

    I just tried adding the line:

    define(‘WP_MEMORY_LIMIT’, ‘128M’:wink:;

    to my wp-config.php file.

    I still cannot view the Snapshot->Settings page.

    Was there anything else I needed to do after adding that line?

    Also, please note that my backups appear to be working fine. Of course, my full site backups are currently only <40M so maybe that’s why I haven’t had an issue yet.

    Thanks,

    Regis

  • Paul
    • The Green Incsub

    @regis_friend_cassidy,

    Try upping this to 256M

    You might not have the same solution as the other member. Was just something I tried and it worked to get him able to view the Settings. And as noted I’ve tried this on three of my own sites running the HTTPS plugins and Snapshot and have not have issue. So forgive me if this takes some time to resolve.

  • regis_friend_cassidy
    • WPMU DEV Initiate

    I do not have a cache plugin installed. Here is what I have:

    WooCommerce version 1.6.6

    WordPress version WP 3.5.1

    Installed plugins

    Cookies for Comments by Donncha O Caoimh version 0.5.4,

    Google Analyticator by Video User Manuals version 6.4.1,

    Quick Page/Post Redirect Plugin by Don Fischer version 5.0.2,

    Regenerate Thumbnails by Viper007Bond version 2.2.4,

    Snapshot by Paul Menard (Incsub) version 2.2,

    WooCommerce New Product Badge by 61 Extensions version 1.0.1,

    WooCommerce PayPal Payments Advanced Gateway by Kiran Polapragada version 1.3,

    WooCommerce Print Invoice/Packing list by Ilari Mäkelä version 2.2.3,

    WooCommerce USPS by Andy Zhang version 2.1.7,

    WooCommerce Subscribe to Newsletter by WooThemes version 1.3.1,

    WooCommerce by WooThemes version 1.6.6,

    WooThemes Updater by WooThemes version 1.0.3,

    WordPress HTTPS by Mike Ems version 3.3.0,

    WordPress SEO by Joost de Valk version 1.3.4.4,

    WP-Mail-SMTP by Callum Macdonald version 0.9.1

  • phillcoxon
    • The Crimson Coder

    I’m out of ideas too for the moment. I’ll think about it some more.

    In the meantime you can try disabling plugins one at a time and see if the error message changes. As Paul mentioned this is often associated with an out of memory issue so if you disable a plugin and the error message changes to something else please let us know.

    In the meantime you could use the cPanel backup function to do a full site backup and then back up the database manually periodically. That way you’re protected with a backup until we can come up with some other ideas.

  • Paul
    • The Green Incsub

    @regis_friend_cassidy, Thanks for the list of plugins. I’m going to try and build an environment with these to see if I can reproduce the issue.

    As phillcoxon mentioned there are many support threads on wordpress.com related to this exact error. Many are related to security or cache plugins. Will keep digging to see if we can help uncover the issue. Thanks.

  • Paul
    • The Green Incsub

    @regis_friend_cassidy,

    So on my personal website I have a real SSL cert. And went into my wp-config.php and set the memory WP_MEMORY_LIMIT to 32M I can hit all the other Snapshot panels but now when I try the Snapshot > Settings I get the error “Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0”

    So from that error state if I go back to my wp-config.php and turn on WP_DEBUG I can then load the Snapshot -> Settings panel. But I get a dozen errors from the theme and various plugins. But these errors don’t show when I then visit any of the other Snapshot panel. Strange.

    At least it is a start into some investigation.

  • Paul
    • The Green Incsub

    @regis_friend_cassidy, No, I’m saying I’m able to reproduce this with my own active plugins. Many of the plugins you listed I do not have. So to confirm I was able to see the same error when I tried loading the Snapshots> Settings page.

    When I enabled WP_DEBUG I was able to actually load the Settings page. But of course I have about a dozen Notices at the top from some other plugins. Once I worked through these and was able to load the page without any reported errors I then turned off PW_DEBUG. Reset my WP_MEMORY_LIMIT to 64M. I was able to load the Settings page as expected.

    I did find one Snapshot error/warning which I’ve patched. It effects single WordPress only not Multisite.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.