Snapshot Pr0 Creates Fatal Error

We installed Snapshot pro. Upon plugin activation, we received a fatal error that referenced the Courspress chat module plugin. The error crashed the site. I'm enclosing a screenshot of the error. We do not want to delete the Courspress pro plugin, as we already have done considerable work with it and do not want to lose our data.

  • Sajid

    Hi Andrew! Hope you are doing good today and thanks for posting in forum :slight_smile:

    It occurs as WordPress tries to access more memory then its allowed to by “Server PHP configuration” or “WordPress Setting”. Increasing Memory will solve it. Here is solution for all user, who have shared hosting or dedicated or VPS, just FTP access to server will be enough.

    1. Try adding this line to your wp-config.php file:
    define(‘WP_MEMORY_LIMIT’, ’64M’);

    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    3. If you don’t have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    You can still increase the memory from 64M possible values are 96M, 128M, 256M, 512M, 1024M, 2048M, 4096M. But lower is the best.

    Hope this helps :slight_smile:

    Cheers, Sajid