[Snapshot Pro] backup fails (Snapshot)

I am getting the error <empty response> when I try to back up. I already have PHP max execution time set to 600. I also set while on with support (unfortunately had to leave before resolved): define('SNAPSHOT_FILESET_CHUNK_SIZE', 10); and define('SNAPSHOT_TABLESET_CHUNK_SIZE', 10);
Other ideas? Thanks!

  • Nastia

    Hello Amelie

    Hope you're doing well!

    Just to clarify is the issue happens with Managed Backup? Please try creating a manual snapshot from Snapshot > Snapshots, will local snapshot backup complete?

    If you're using Managed Backup, it backups the whole public_html folder, if there are other folders/sites please make sure there is efficient storage space to back up these files. The Snapshot plugin first needs to create a local copy on your server and after this, it is uploading the file to the WPMU DEV Cloud.

    If you have enough storage, please enable debug by adding the following lines in the wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    /*track all errors*/
    define('SNAPSHOT_BACKTRACE_ALL', true);

    Run the Managed Backup again. This will create a debug.log file in the wp-content folder. Please rename the debug.log to debug.txt file and attach it here.

    Let us know how it went!

    Cheers,
    Nastia

  • Amelie

    With Snapshot I get: AAA An unknown response returned from Snapshot backup attempt. Aborting.

    Debugging, I get:
    [10-Jul-2018 20:55:30 UTC] PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 16777224 bytes) in /public_html/wp-content/plugins/snapshot/lib/Snapshot/Helper/Utility.php on line 537

    Looks perhaps like memory issue? Is there something besides max execution time that I should up?

    By the way, is there a way to have Managed Backup NOT save everything in public_html? There are directories that are not WordPress there (that I need, a lot of other things going on).

  • Nahid

    Hey Amelie !
    Hope you are doing well today!

    Looking at the error log that you shared in your last response, it seems like PHP's memory_limit is causing the issue. Could you try increasing it to a value of at least 512M (or more, if possible) and see if that makes a difference? The best approach to do that would be getting in touch with your host support and requesting them to increase it. You can also try doing it yourself by following this handy guide.

    Is there a way to have Managed Backup NOT save everything in public_html?

    By default, Snapshot's Managed Backups create a full backup of the site directory. However, specific folders/directories can be excluded from the backup by adding them in the "Global File Exclusions" option located in your WordPress Dashboard->Snapshot->Settings. Here's a screenshot for reference:

    Hope this helps. Let us know if this works for you. Thanks!

    Kind regards,
    Nahid

  • Dimitris

    Hello there Amelie,

    hope you're doing good and don't mind me chip in here! :slight_smile:

    Could you please edit wp-config.php and add the following lines just above the "/* That's all, stop editing! Happy blogging. */" comment:

    // Snapshot settings - start
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600); //100MB
    define('SNAPSHOT_IGNORE_SYMLINKS',true);
    define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_BACKTRACE_ALL', true);
    define('SNAPSHOT_SYSTEM_DEBUG_OUTPUT', true);
    // Snapshot settings - end

    Then give Managed Backups another try.

    If you're dealing with errors again, please do share the updated wp-content/debug.log file. You should have to rename it into .txt, if you want to attach it here, and it should be less than 5MB. If it's larger, upload it in a service like Dropbox or Google Drive and post the shareable link in your next reply. Finally, grant support access for us, as shown here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5
    Please do reply back here when access is granted because we don't get any notifications about it. :slight_smile:

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.