Snapshot Pro backup not working.

Snapshot backup has not been working since Aug. 10th. After running for a while it gives 503 error and stuck. Please help.

  • Adam Czajczyk

    Hello Darryl

    Thank you for reaching out to us.

    I have accessed your site via support access and checked it. Things that I did on site (exactly, nothing less and nothing more) were:

    - checking current PHP settings by going to the "WPMU DEV -> Support -> System Info" page and looking at the information there
    - checking "error_log" and "debug.log" files from the server (downloaded via FTP) against potential error messages that could help diagnose it
    - running Snapshot (named "Snapshot WPMU TEST" - only this one) a couple of times, while watching browser console against possible issues.

    No other actions or changes were taken on the site by me. This, however, shows that this is an issue that goes most likely a bit "deeper" than the Snapshot plugin itself. The 503 error happens usually if the server is not able to allocate more resources for a given process. PHP and WP configuration looks fine so in similar cases that usually is an issue of I/O (so basically file read/write operations on a server) limits being exhausted.

    In most cases, there's a simple workaround for this: instead of running a single "snapshot", setting up multiple smaller ones (e.g. one for db files, one for plugins, one for media files etc). However, I have tried to run snapshot to backup only database and that also failed with the same error, each time I tried it happened at a different point.

    Furthermore, the 503 error also happened while the snapshot was not running at all, which actually suggests that there might be some additional server limits (like for example number of concurrent db queries or webserver connections) that are too low for the site to function properly.

    That being said, I have asked our developers directly to take a look into it so they could examine the site and check what might be causing this. However, I would also like to ask you for one more thing:

    Could you please get in touch with your host tech support and ask them if they could check if they can find any information in server logs about any server-side limits being hit, probably around the time I was testing the site, which was around 2pm UTC time? If they can confirm that, let me know, please what/which limits were those.

    That could help us diagnose the issue and look for the solution.

    Kind regards,
    Adam

  • Darryl

    The reply from Green Geeks to your inquiry is below... note: they say that I am hitting maximums of resource allocations... but on this account I have 3 drupal sites all in maintenance mode and no traffic.... and 1 WP multisite that you are working one... hard to believe that I am maxing out resources on sites with ZERO traffic

    This Green Geeks reply to your inquiry:

    Hello,

    Below is the Resource Usage log (Can also be found from inside your cPanel):

    ###
    From To aCPU mCpu lCPU aEP mEP lEP aMem mMem lMem MemF MepF
    |09-16 12:36|09-16 13:36|10 |40 |200 |1 |1 |100|48.3MB|368MB |0B |0 |0 |93.3MB|386MB |386MB|1 |7 |100 |1.3K |0 |138KB |4.0MB |4.0MB|9 |210 |4.0K |
    |09-16 13:36|09-16 14:36|21 |73 |200 |1 |1 |100|82.7MB|407MB |0B |0 |0 |104MB |386MB |386MB|1 |7 |100 |2.3K |0 |435KB |4.0MB |4.0MB|30 |251 |4.0K |
    |09-16 14:36|09-16 15:36|19 |59 |200 |1 |1 |100|74.9MB|396MB |0B |0 |0 |97.0MB|386MB |386MB|1 |8 |100 |2.5K |0 |267KB |3.8MB |4.0MB|19 |241 |4.0K |
    |09-16 15:36|09-16 16:36|13 |59 |200 |1 |1 |100|62.9MB|201MB |0B |0 |0 |102MB |386MB |386MB|0 |2 |100 |84 |0 |605KB |4.0MB |4.0MB|10 |88 |4.0K |
    |09-16 16:36|09-16 17:36|12 |69 |200 |1 |1 |100|66.3MB|279MB |0B |0 |0 |103MB |386MB |386MB|0 |3 |100 |10 |0 |600KB |4.0MB |4.0MB|10 |71 |4.0K |
    |09-16 17:36|09-16 18:36|15 |65 |200 |1 |1 |100|58.8MB|265MB |0B |0 |0 |110MB |386MB |386MB|1 |3 |100 |80 |0 |592KB |4.0MB |4.0MB|14 |156 |4.0K |
    |09-16 18:36|09-16 19:36|15 |71 |200 |1 |1 |100|52.7MB|229MB |0B |0 |0 |83.6MB|386MB |386MB|0 |2 |100 |72 |0 |240KB |4.0MB |4.0MB|6 |58 |4.0K |
    |09-16 19:36|09-16 20:36|13 |91 |200 |1 |1 |100|44.8MB|260MB |0B |0 |0 |76.8MB|386MB |386MB|0 |2 |100 |9 |0 |201KB |2.3MB |4.0MB|4 |71 |4.0K |
    |09-16 20:36|09-16 21:36|5 |15 |200 |1 |2 |100|27.5MB|56.7MB|0B |0 |0 |63.2MB|386MB |386MB|1 |4 |100 |26 |0 |17.3KB|515KB |4.0MB|2 |38 |4.0K |
    |09-16 21:36|09-16 22:36|10 |37 |200 |1 |1 |100|46.7MB|164MB |0B |0 |0 |69.6MB|386MB |386MB|2 |4 |100 |1.8K |0 |314KB |1.6MB |4.0MB|22 |122 |4.0K |
    |09-16 22:36|09-16 23:36|8 |40 |200 |1 |1 |100|34.5MB|194MB |0B |0 |0 |58.0MB|386MB |386MB|0 |3 |100 |944 |0 |112KB |1.4MB |4.0MB|8 |108 |4.0K |
    |09-16 23:36|09-17 00:36|4 |27 |200 |1 |1 |100|20.5MB|77.7MB|0B |0 |0 |47.7MB|103MB |386MB|0 |1 |100 |0 |0 |8.1KB |126KB |4.0MB|1 |8 |4.0K |
    |09-17 00:36|09-17 01:36|5 |21 |200 |1 |1 |100|18.4MB|46.2MB|0B |0 |0 |48.4MB|386MB |386MB|0 |1 |100 |18 |0 |39.8KB|771KB |4.0MB|3 |50 |4.0K |
    |09-17 01:36|09-17 02:36|3 |21 |200 |1 |1 |100|14.6MB|73.8MB|0B |0 |0 |68.5MB|120MB |386MB|0 |1 |100 |0 |0 |711B |17.4KB|4.0MB|0 |1 |4.0K |
    |09-17 02:36|09-17 03:36|11 |42 |200 |1 |1 |100|72.7MB|458MB |0B |0 |0 |135MB |386MB |386MB|1 |11 |100 |6.8K |0 |1003KB|4.0MB |4.0MB|43 |267 |4.0K |
    |09-17 03:36|09-17 04:36|6 |54 |200 |1 |1 |100|30.2MB|384MB |0B |0 |0 |93.5MB|386MB |386MB|0 |10 |100 |2.9K |0 |86.8KB|3.6MB |4.0MB|6 |251 |4.0K |
    |09-17 04:36|09-17 05:36|7 |19 |200 |1 |1 |100|19.5MB|46.2MB|0B |0 |0 |92.7MB|118MB |386MB|0 |1 |100 |0 |0 |27.5KB|268KB |4.0MB|2 |20 |4.0K |
    |09-17 05:36|09-17 06:36|3 |15 |200 |1 |1 |100|14.8MB|56.2MB|0B |0 |0 |61.0MB|106MB |386MB|0 |1 |100 |0 |0 |65.1KB|1.6MB |4.0MB|3 |58 |4.0K |
    |09-17 06:36|09-17 07:36|23 |86 |200 |1 |1 |100|83.0MB|436MB |0B |0 |0 |114MB |386MB |386MB|1 |8 |100 |2.7K |0 |749KB |4.0MB |4.0MB|18 |238 |4.0K |
    |09-17 07:36|09-17 08:36|7 |24 |200 |1 |1 |100|29.4MB|90.8MB|0B |0 |0 |70.1MB|386MB |386MB|0 |1 |100 |14 |0 |35.2KB|559KB |4.0MB|2 |26 |4.0K |
    ###

    Below is the explanation of each heading/column.

    "From" "to" - period of time
    "aCPU" - Average CPU usage
    "mCPU" - Max CPU usage
    "lCPU" - CPU Limit
    "aEP" - Average Entry Processes
    "mEP" - Max Entry Processes
    "lEP" - maxEntryProc limit
    "aMEM" - Average Memory Usage
    "mMEM" - Max Memory Usage
    "lMEM" - Memory Limit
    "MemF" - Out Of Memory Faults
    "MepF" - Max Entry processes faults
    ###

    Your account was reaching Memory and I/O limits.
    To make sure that the account's PHP environment matches WordPress requirements and today's industry standards, and system resources are used the optimal way, PHP version was adjusted as per https://wordpress.org/about/requirements/ and relevant PHP parameters, like max_execution_time and memory_limit, were set to maximums via cPanel's "Select PHP version" section as per https://kb.greengeeks.com/2338/configuring-php-environment-variables-through-your-custom-php-ini/

    Please get back to us if you need any further assistance and let us know how else we can help.

    Thank you and have a great day,

  • Panos

    Hi Darryl ,

    We have been doing a few tests on your site. Since it completes when using only a few files, but it times out using all files, it is up to server resources. Specifically, when plugins and uploads folders are included in the zip file it always times out. The server can't handle the size of the zip file so it can't continue the process.

    WordPress plugins work with php, so does Snapshot. PHP adds more overhead to those processes requiring even more server resources. We could exclude files and keep a backup f the db only.

    For plugins and uploads files, if your host supports the exec funciton we could try keeping some custom zips with a custom snippet, eg:
    exec( 'cd ' . WP_CONTENT_DIR . ' && zip -r plugins.zip . -i /plugins/*' )
    Usually though, exec is disabled by hosts (eg with disable_functions in php.ini) so it might not be possible.

    Those custom zip files though, won't be used by Snapshot, so restoring those should be done manually or would require another custom snippet.

    Please let us know if you would like us to give that a try :slight_smile:

    Kind regards!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.