[Snapshot Pro] Cannot Restore Snapshot

My site on my network lost all pages except homepage. I'm not sure when or how this happened.

So, I am trying to restore it using snapshot.

I have tried multiple times with different snapshot versions on two different networks with new sites.

None of them work. I receive this message "An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings."

I already did a plugin/theme conflict test.

  • Ash
    • WordPress Hacker

    Hello Eric Johnson

    I guess you were trying to restore from regular snapshot as you were trying to restore a subsite. This may happen due to an error. Would you please enable debug mode and check if there is any error? To enable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', false );

    to

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Now try to restore again. That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

    If you don't find any error, then please let me know which backup you are trying to restore and on which site (should I try on new subsite or existing subsite).

    Have a nice day!

    Cheers,
    Ash

  • Nithin
    • Support Wizard

    Hi Eric Johnson,

    Hope you are doing good today. :slight_smile:

    Thanks for sharing the debug logs, I checked the logs, and could notice the following Fatal error:
    PHP Fatal error: Out of memory (allocated 588398592) (tried to allocate 257496600 bytes) in /wp-content/plugins/snapshot/lib/Snapshot/Model/Database/Backup.php on line 480

    This happens when the server resources is running out of memory limit, or isn't inadequate. Since Support access to your website wasn't enabled, I wasn't able to give a look at the existing memory limit, under WPMU DEV > Support > System Info page.

    You can check the following article on how to increase the servers memory resources:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    Which basically states, to increase your memory limit, you'll have to create a php.ini file inside your root directory, and add the following rules to it:
    For eg:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 300

    If you aren't able to increase your memory limit, would recommend you to get in touch with your host, in order to increase these values.

    I hope this helps, please let us know how that goes. Have a great day ahead. :slight_smile:

    Regards,
    Nithin

  • Eric Johnson
    • The Incredible Code Injector

    Hi Nithin,

    Actually, I think I followed those instructions before and was able to change all except the max filesize and post max size.

    For some reason I'm stuck at 64M for both.

    Any other work arounds?

    I recall in the past for other sites I had no problem changing them.

    Have a great day, Thanks
    -Eric

    edit: I just found in the php.ini file that the limits are 1000M and 2000M. Can they be overridden by another file keeping them lower?

  • Nithin
    • Support Wizard

    Hi Eric Johnson,

    That's really odd, we'll need to troubleshoot this further to see what's causing this. Could you please send us your credentials, so that we could give a closer look.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Please follow up in the ticket once you have sent the details, so that we would get notified, and troubleshoot this extensively. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Eric Johnson
    • The Incredible Code Injector

    Hi Nithin,

    I was playing around with restoring the snapshot to another network.

    What I found is that something with the post db is preventing the full restore. With it unselected I can get the front page to restore, minus the menu.

    - Eric

  • Nithin
    • Support Wizard

    Hi Eric Johnson,

    Sorry for the delay in getting back to you. Thanks for sharing the login credentials, I tried to log into the dashboard, but it seems like the /wp-admin login URL has been changed, or masked. I'm afraid, I wasn't able to log with the shared credentials without knowing the correct login URL for the WordPress dashboard, nor the support access seems to be enabled.

    Seemed like it was a feature of Defender plugin, so I quickly tried to deactivate the plugin via FTP to access the dashboard, but still the same issue. Could you please share the correct login URL for the WordPress dashboard, or enable support access, so I could give a closer look at it?

    Please let us know once you have enabled access, so we could give a closer look at the observations you have made in your previous reply.

    Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Eric Johnson,

    I tried to access your WordPress dashboard, and I'm afraid I'm getting the following message:

    Could you please point out what's being missed? I was able to login via support access temporarily,
    but it seemed like, the support access also got expired at the moment.

    I was able to go through the regular snapshot in your system via support access, however I don't see any exact Snapshot dated August for 3 pillars Snaphot as mentioned in the above ticket. Could you please point out which is the right snapshot for 3 pillars? I could notice 2 snapshots.

    I was looking forward to run a restore from one of the existing 3 pillars snapshot by creating a new subsite, but unfortunately support access wasn't working past that.

    Checking via FTP, I could notice the Out of memory error in the debug log dated for 15th November, however checking the server configuration it looks the memory_limit, and the other configs do have enough resources to run a restore.

    I tested with usernames "wpmu", and also "wpmu@fixufit.com", both didn't work. If there is a change in password please do re-share the login credentials the same way as done before, so that I could check this with our developer, and see whether there is any further improvement that could be done.

    Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Eric Johnson,

    Hope you are doing good today. :slight_smile:

    Thanks for making the changes, the login is working fine. I further tested this out in the system, by creating a new test subsite, and with the 3 Pillars Snapshot on August, and the issue still exists. I could notice the memory limit issue, which is an odd behaviour, when I check the PHP Info page, the memory seems adequate.

    I'm bringing this issue into our Second Level Support (SLS) teams attention, to see whether there is anything that could be done within the plugin side to help get this fixed.

    Please do note that our SLS team work on complex issues, and hence have a slow response time, we'll get back to you via this ticket, once it's extensively tested asap.

    Regards,
    Nithin

  • Panos
    • SLS

    Hi Eric Johnson ,

    It's been a long time and I would like to apologize for delay. I did check a while ago but I didn't see that backup there. Unfortunately I missed informing you back then. In case you haven't resolved this, could you send in that backup. You can share a download link so I could try it out.

    Kind regards!

  • Panos
    • SLS

    Hi Eric Johnson ,

    It is related to the size of data and the server resources available. More specifically, when it tries to create the restore options table, it meats a really big row. This one uf-fixer-regions-global, and it throws the following error message:
    database error Got a packet bigger than 'max_allowed_packet' bytes for query
    It can be increased but probably only your host would have access : https://dev.mysql.com/doc/refman/5.5/en/packet-too-large.html

    I think it's worth asking your host if it could be increased, in case there are similar huge rows,

    Kind regards!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.