[Snapshot Pro] Cannot run backups and other problems!

Hello I am having multiple problems with your system. Out of all the sites we have added we are only able to backup 2 which is very poor for this service. the progressbar just stays at 0% and does not progress. Also having problems with Defender Pro, the file scanner is not working it gets stuck in about 30% Please help us we paid alot of money for this and expect a functional product

  • Nithin

    Hi Networking Bizz Digital,

    Sorry to hear you are having issues with making the plugin work. Could you please add the following rules inside wp-config.php file, and see whether it improves with taking Managed Backups without any issue.

    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_IGNORE_SYMLINKS', true);

    Please make sure to place the above code, just before the line /* That's all, stop editing! Happy blogging. */. wp-config.php is located inside the root directory, you'll have to use FTP, or cPanel to make the changes.

    Once done please check how Managed Backup via Snaphot goes, if you still have issues, would recommend you enable support access to your site, so that we could give a closer look at the issues raised.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Networking Bizz Digital

    Hello, Nithin!

    We have tried and used the FTP access to insert the code provided. However, inserting the code into the wp-config file make the site inoperable, so we had to revert back to the original version of the wp-config file.

    We also attempted to remedy the issue by increasing the maximum upload and PHP memory limit and enabling PHP zip archive module to clear the error for Snapshot Pro. However, this seemed to only work for one website (www.kweiquartey.com), and even then it did not seem to back up the site completely. The backup file is small, only 5 kb, which does seem to accurately reflect the size of the website.

    For another website (www.loadedcafe.com), the errors cleared. However, Snapshot Pro does not create a full backup. When the progress bar reaches 73%, it no longer progresses and after some time, the page bugs and we are left with "404" error. When we refresh the error clears, but no backups are made and the process begins again.

    For yet another website (www.newasiainconline.com), we have tried all three methods of FTP changes and code insertion, however, the "max_execution_time" error does not clear.

    For Defender, the changes made seemed to clear the error, but we are not sure why.

    We would really like to get to the bottom of this to continue using your Dev Dashboard.

  • Kris

    Hi Networking Bizz Digital

    We have tried and used the FTP access to insert the code provided. However, inserting the code into the wp-config file make the site inoperable, so we had to revert back to the original version of the wp-config file.

    Just to be sure, does code was added before the line /* That's all, stop editing! Happy blogging. */ in wp-config.php file. This is uncommon case.

    We also attempted to remedy the issue by increasing the maximum upload and PHP memory limit and enabling PHP zip archive module to clear the error for Snapshot Pro. However, this seemed to only work for one website (www.kweiquartey.com), and even then it did not seem to back up the site completely. The backup file is small, only 5 kb, which does seem to accurately reflect the size of the website.

    For another website (www.loadedcafe.com), the errors cleared. However, Snapshot Pro does not create a full backup. When the progress bar reaches 73%, it no longer progresses and after some time, the page bugs and we are left with "404" error. When we refresh the error clears, but no backups are made and the process begins again.

    For yet another website (www.newasiainconline.com), we have tried all three methods of FTP changes and code insertion, however, the "max_execution_time" error does not clear.

    There could be many reason of this, for excample large file in media folder or many files like more that 2000 in one month folder, or even other backup plugin folder which contains large ZIP files which need to be exclude in Snapshot (in case you use any other backup plugin before).

    For Defender, the changes made seemed to clear the error, but we are not sure why.

    In this case max_execution_time value helps in most cases. Defender need more time to finish whole scan for all files if site is bigger (many files to check in case of many plugins).

    Summarizing we will be happy to help you with those issues. To do that we will need additional access from you to investigate this more. Please don't share any sensitive information (i.e credentials) in the Support Forum, it has public visibility and everyone will have access to it.

    To do that please send it through our secure contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question and make sure that subject is "I have a different question" and:
    - Mark to my attention: ATTN: Krzysztof Tomczyk
    - http://www.kweiquartey.com access (login url / username / password)
    - http://www.loadedcafe.com access (login url / username / password)
    - http://www.newasiainconline.com access (login url / username / password)
    - cPanel details where we could check server values and have access to file manager to review FTP files and folder (host url / username / password)

    - Link back to this thread

    Please confirm here in thread that you have sent that message.

    Kind Regards,
    Kris

  • Nithin

    Hi Networking Bizz Digital,

    Thanks for sending in the login credentials, unfortunately the WP logins shared for the sites:
    http://kweiquartey.com/
    http://loadedcafe.com/
    http://www.newasiainconline.com

    Doesn't seem to be having administrator permissions, so I wasn't able to check the Snapshot issue in further via the dashboard.

    Regarding the cPanel logins shared, I'm afraid, the cPanel login URL for the following sites isn't clear:

    http://kweiquartey.com/
    http://loadedcafe.com/

    I tried the following path, for the both the sites:
    http://kweiquartey.com:2083

    But it isn't working. The cPanel works for newasiainconline.com but, it seems like the WordPress site is down when I check.

    Could you please advise what's being missed, or if there is any changes in the login credentials the same way as done before.

    Looking forward to your reply, so that we could give a closer look at the Snapshot issue further.

    Regards,
    Nithin

  • Nithin

    Hi Networking Bizz Digital,

    Hope you are doing good today. :slight_smile:

    It looks like all the mentioned websites are running in the same server? Could you please confirm regarding this. If yes, then checking what could be causing the issue with one site, would give a better idea about the other sites too.

    To start with, I tested with http://www.kweiquartey.com website, and I could notice the backup is failing after a while. I added the following rules inside wp-config.php file:

    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_IGNORE_SYMLINKS', true);

    And enabled debug mode, and could notice the following error:

    [02-Jan-2019 07:48:47 UTC] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 524288 bytes) in /xxx/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Fileset.php on line 177

    The above error means that there isn't enough memory for the plugin to finish it's backup process. I tried excluding bigger files via Snapshot settings, and I could notice 524 error once then.

    Now, when I try to load the website, the website isn't loading at all in my side, and it seems to be related to the high I/O usage, and the Process entry as seen in cPanel:

    524 error occurs due to inadequate resources, the current memory_limit is 128M in your mentioned site.

    I then checked the Defender San, and ran a new scan, and could notice the following issue in the debug mode:
    [02-Jan-2019 10:52:21 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 1292091 bytes) in /public_html/wp-includes/wp-db.php on line 1185
    This is also related to having a low memory limit.

    So, I increase the resources via the php.ini in the root folder by adding the following rules:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 600

    The above seems to have fixed the issue with Defender File Scaning, and it works fine, when I try a new File Scanning via Defender . Also, please do update PHP version from 5.6 to PHP 7.0 or greater. PHP 7 is considered very fast when compared to 5.6, and this should also help improve the sites overall performance.

    After the resources were increased, I re-ran a new Managed Backup in Snapshot again, but could notice 524 error.

    About http://loadedcafe.com website, I added the above changes in the wp-config.php file, and ran a new backup, and it also ended up with 524 error.

    524 error normally occurs when the server resources exceeds the limits, and is most related to the server side. Could you please check with your hosting provider, regarding which exact process they notice where the resources limits are reached, so that we could have a better idea regarding how to move forward with it.

    Then checked http://newasiainconline.com/ site, and I could notice that the Snapshot Managed Backup page isn't loading stylesheet properly.

    This looks more like a conflict, is the mentioned site a live site? I didn't perform any conflict test without confirming with you. Is it possible for you to disable all the existing plugin in your system, except WPMU DEV Dashboard, and Snapshot to see how the pages in Snapshot behaves once done?

    If the pages load fine, then please make the changes in the wp-config.php file as mentioned above, and run a new Managed Backup to see how the backup goes.

    This would give a better idea where the issue is located in newasiainconline.com website. Please let us know how that goes. Have a nice day ahead. :slight_smile:

    Regards,
    Nithin

  • Networking Bizz Digital

    The sites are not running on the same server. They are all hosted in different locations.

    We will see about updating PHP version from 5.6 to PHP 7.0 or greater on kweiquartey.com.

    We will also contact the hosting provider for loadedcafe.com in regards to the 524 error.

    As for newasiainconline.com, it is indeed live. Would performing the plugin test affect the live site? We do not want to have the site affected by deactivating certain plugins. Would we not

    But with all due respect, we cannot be using our own developers and having to perform separate processes for each of these sites every time we want to use this plugin, such as php updates. It simply isn't efficient.

  • Nithin

    Hi Networking Bizz Digital,

    As for newasiainconline.com, it is indeed live. Would performing the plugin test affect the live site? We do not want to have the site affected by deactivating certain plugins. Would we not

    If it's a live site, then wouldn't recommend running plugin conflicts. The issue seen as shared in the screenshot is more related to a conflict, I'm afraid, I only see that running a plugin conflict test, would give a better idea where the issue is.

    Maybe, you could check with your hosting provider, and ask to setup a staging site, where a conflict test could be performed? This would give a better idea where the issue is located, and hence help improve the plugin, in case the conflict is related to Snapshot.

    We have a new release of Snapshot Pro v 3.2. Would recommend you to update the plugin, and check whether it makes any difference too.

    we cannot be using our own developers and having to perform separate processes for each of these sites every time we want to use this plugin, such as php updates. It simply isn't efficient.

    I do understand you, but there could be numerous reasons for the plugin to not work, or not preform a successful backups. This would vary from one site to another, and I'm afraid, there isn't any one step solutions regarding this, other than troubleshooting the issue manually for each site.

    Factors like Server resources, size of the site, plugin, or themes conflicts etc are something which varies from one site to another, so how a plugin would work based on these factors are subjective.

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.