[Snapshot Pro] Can't add google drive back up destination it keep show 404 error.

I am facing an issue with adding the destination of google drive in snapshot but it not save the destination show 404 error.

  • Dimitris
    • Support Star

    Hello there Netzsolutions

    I checked your website and noticed a lot of 404 errors happening right after trying to add a new destination from Snapshot -> Destination -> Google Drive - Add Destination, so this seems more like a conflict with another plugin or active theme, as I wasn't able to replicate in a testing site of mine and the issue occurs before actually trying to save any settings there.

    In order to narrow this down, a full conflict test should be made. First, create a recent backup in case you lose any settings during the test and have to restore to a previous working state.
    Then deactivate all plugins and MU-plugins apart from WPMUDEV Dashboard and Snapshot, activate a default theme like TwentySeventeen, clear all caches and check again if the issue is still there. If not, it means that something is conflicting, so start activating the remaining plugins and theme, one by one this time, checking every time for the reported issue, until you reproduce the issue, thus finding the conflicted combination. The following flowchart image can assist you during this test: https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif
    If this is a live website with traffic, I'd rather advise to create a staging environment, meaning a complete and exact copy of this installation into another location/folder in the same server, using a separate database, and perform the test in there instead without worrying about the live site. Reference: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    Looking forward to your results! :slight_smile:
    Thank you,
    Dimitris

    • Netzsolutions
      • New Recruit

      Hello Dimitris,

      Thanks for the reply, we would like to update you that we have configured the website on the staging server and we have taken the same steps which you mentioned above, but it is not working and we face the same error. Please check and let me know.

      Looking forward! :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.