[Snapshot Pro] Can't complete backup

Hi there,

I have another backup issue. I try to run a managed or manual backup but it never completes. My server shows that I/O usage has reached its max (it's set at 10MB/s) during the backup process.

I run Snapshot on other websites on the same server and they don't have any issues.

I have activated support from the dashboard for you to take a look

Thanks

  • Nebu John
    • Staff

    Hi Anastasiya,

    Hope you are doing good today.

    I am really sorry about the inconveniences you are having with regards to using our Snapshot plugin and I hope we resolve it soon.

    While running a manual backup, I noticed a 524 Time out error returned. Can you try creating a mu-plugin with the code given below?

    <?php
    function snapshot_custom_size_increment() {
        return 5 * 1024 * 1024;
     }
     add_filter( 'snapshot_model_transfer_part_size_increment', 'snapshot_custom_size_increment' );

    This splits the upload process into smaller chunks so the server can properly handle it as it was timing out. To create a mu-plugin, go to wp-content/mu-plugins folder. If there is no mu-plugins folder then, create one. Now, inside the mu-plugins folder create file with name anything.php (make sure file extension is .php).

    You could find more about mu-plugins from this link https://wordpress.org/support/article/must-use-plugins/

    Hope it helps! Please feel free to ask more questions if you have any.

    Kind Regards,
    Nebu John

  • Nebu John
    • Staff

    Hi Anastasiya,

    Sorry to read that solution didn't work well for you.

    This might be a problem with CloudFlare. Would you be able to disable CloudFlare for this site and check if manual backup's work?

    Also for further investigation, can you provide us with FTP/cPanel access. Please follow the below procedure to provide us the details.

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:
    NOTE: Don't change the selected topic in the dropdown, just leave it at "I have a different question".

    Subject: "Attn: Nebu John"
    - FTP/cPanel credentials (host/username/password)
    - Folder path to the site in question
    - Link back to this thread for reference
    - Any other relevant URLs/info

    Kind Regards,
    Nebu John

  • Anastasiya
    • Flash Drive

    I just submitted the contact form with all the details. I look forward to hearing back from you.

    Disabling Cloudflare is not an option. It will mess up SSL and DNS for the website that would result in insecure website warnings. I have the exact same setup on several other website, Cloudflare has never been an issue.

  • Nebu John
    • Staff

    Hi Anastasiya,

    Hope you are doing good today. :slight_smile:

    Thank you for providing us with access credentials.

    From the statistics in cPanel, I was able to identify that I/O usage and Physical memory usage max out when a Managed Backup is initiated.

    I further troubleshoot the issue and tried adding more tweaks in the Snapshot plugin side to see how the Managed Backup behaves. By adding below given code in 'wp-config.php' file was able to complete Managed Backup with Snapshot.

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 30);
    define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');

    Find the attached image below.

    However, I have enabled scheduled backup on day frequency to find if it works fine. You may later change this to your desired frequency.

    Kind Regards,
    Nebu John

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.