[Snapshot Pro] Can't take snapshot

I installed the zip file in Cpanel as instructed, but still not working.

  • Majid

    Hey Jill
    I hope you are doing great :slight_smile:

    I'm sorry but the thread wasn't clear enough, Do you mean the full backup zip file ? If that's the case then you should upload the zip file to the root of your WordPress alongside the file called snapshot-installer.php which you can download from the hub also as a zip format.

    Please explain further so I can help you accurately :slight_smile:

    Thank you !
    Majid

  • Dimitris

    Hey there Jill,

    hope you're doing good today and don't mind chip in here! :slight_smile:

    I've removed the website link, as our forums are publicly available and I was already seeing the website you've selected upon thread creation. Please be extra careful about any kind of sensitive information you post.

    Now, about the issue itself, I can see that you've already created a normal snapshot and uploaded it to a Dropbox destination, so I guess that this works well, but Managed Backups are empty, so I guess that's the part that doesn't work for you.
    Please do correct me, if I miss something here!

    I tried to run a new Managed Backup but support access is automatically logging us off after one hour, so wasn't able to complete it anyway (was working good, up to that point though).

    Could you please follow the instructions shown here https://premium.wpmudev.org/blog/increase-memory-limit/ in order to set the followings:

    max_execution_time = 300
    default_socket_timeout = 300
    memory_limit = 1024M

    I can see that you've set max_execution_time to 0, which is equal to infinite, but this isn't always a good technique, as other server limits may occur and limit that down again.

    After doing so, make sure that new values are shown here:
    https://www.yordomain.com/new/wp-admin/admin.php?page=wpmudev-support&view=system#tab-php

    Then access your server via FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);
    
    define('WP_MEMORY_LIMIT', '512M');
    define('WP_MAX_MEMORY_LIMIT', '1024M');
    
    define('SNAPSHOT_IGNORE_SYMLINKS',true);
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_BACKTRACE_ALL', true);
    define('SNAPSHOT_SYSTEM_DEBUG_OUTPUT', true);

    Finally, go ahead and try to run a new Managed Backup. Keep the browser tab opened at all times and if it halts again, download /wp-content/debug.log file, rename it to debug.txt and attach it here in your next reply. If size of text file exceeds the 5MB limit of our blog, please use a service like Dropbox and post the shareable link instead.
    Ref: https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.